Displaylink driver could not be installed

Hi everyone,

I’m trying to setup my displaylink device on my Laptop to use two other monitors additionally. Unfortunately, the installation of the AUR package fails with the following message:

Vorbereitung...
Klone displaylink Build-Dateien...
Überprüfe displaylink Abhängigkeiten...
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...

Erstelle displaylink...
==> Erstelle Paket: displaylink 5.3.1.34-4 (Fr 23 Okt 2020 17:15:02 CEST)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> displaylink-driver-5.3.1.34.zip gefunden
  -> udev.sh gefunden
  -> 99-displaylink.rules gefunden
  -> displaylink.service gefunden
  -> displaylink-sleep.sh gefunden
==> Überprüfe source Dateien mit sha256sums...
    displaylink-driver-5.3.1.34.zip ... Durchgelaufen
    udev.sh ... Durchgelaufen
    99-displaylink.rules ... Durchgelaufen
    displaylink.service ... Durchgelaufen
    displaylink-sleep.sh ... Durchgelaufen
==> Entferne existierendes $srcdir/ Verzeichnis...
==> Entpacke Quellen...
  -> Entpacke displaylink-driver-5.3.1.34.zip mit bsdtar
==> Entferne existierendes $pkgdir/ Verzeichnis...
==> Betrete fakeroot Umgebung...
==> Beginne package()...
Adding udev rule for DisplayLink DL-3xxx/5xxx devices
Installing DLM systemd service
Extracting DisplayLink Driver Package
Failed to create /root/.cache for shader cache (Keine Berechtigung)---disabling.
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/var/tmp/pamac-build-xxx/displaylink/PKGBUILD: Zeile 50: cd: displaylink-5.3.1.34: Datei oder Verzeichnis nicht gefunden
==> FEHLER: Ein Fehler geschah in package().
    Breche ab...

Further Information to my system:

Generated on 2020-10-23 17:22:1603466541

#################### lsusb -vt ########################

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
        ID 2109:8110 VIA Labs, Inc. Hub
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=, 5000M
            ID 17e9:4307 DisplayLink 
        |__ Port 1: Dev 3, If 1, Class=Application Specific Interface, Driver=, 5000M
            ID 17e9:4307 DisplayLink 
        |__ Port 1: Dev 3, If 2, Class=Audio, Driver=snd-usb-audio, 5000M
            ID 17e9:4307 DisplayLink 
        |__ Port 1: Dev 3, If 3, Class=Audio, Driver=snd-usb-audio, 5000M
            ID 17e9:4307 DisplayLink 
        |__ Port 1: Dev 3, If 4, Class=Audio, Driver=snd-usb-audio, 5000M
            ID 17e9:4307 DisplayLink 
        |__ Port 1: Dev 3, If 5, Class=Communications, Driver=cdc_ncm, 5000M
            ID 17e9:4307 DisplayLink 
        |__ Port 1: Dev 3, If 6, Class=CDC Data, Driver=cdc_ncm, 5000M
            ID 17e9:4307 DisplayLink 
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/12p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        ID 2109:2811 VIA Labs, Inc. Hub
        |__ Port 4: Dev 4, If 0, Class=Hub, Driver=hub/4p, 480M
            ID 1a40:0101 Terminus Technology Inc. Hub
            |__ Port 4: Dev 11, If 0, Class=Human Interface Device, Driver=usbhid, 12M
                ID 062a:4102 MosArt Semiconductor Corp. Wireless Mouse
            |__ Port 3: Dev 9, If 0, Class=Human Interface Device, Driver=usbhid, 12M
                ID 25a7:fa23 Areson Technology Corp 2.4G Receiver
            |__ Port 3: Dev 9, If 1, Class=Human Interface Device, Driver=usbhid, 12M
                ID 25a7:fa23 Areson Technology Corp 2.4G Receiver
            |__ Port 1: Dev 6, If 0, Class=Mass Storage, Driver=usb-storage, 480M
                ID 0781:5583 SanDisk Corp. Ultra Fit
    |__ Port 3: Dev 3, If 0, Class=Audio, Driver=snd-usb-audio, 12M
        ID 0b0e:a346 GN Netcom Jabra Engage 75 Stereo
    |__ Port 3: Dev 3, If 1, Class=Audio, Driver=snd-usb-audio, 12M
        ID 0b0e:a346 GN Netcom Jabra Engage 75 Stereo
    |__ Port 3: Dev 3, If 2, Class=Audio, Driver=snd-usb-audio, 12M
        ID 0b0e:a346 GN Netcom Jabra Engage 75 Stereo
    |__ Port 3: Dev 3, If 3, Class=Human Interface Device, Driver=usbhid, 12M
        ID 0b0e:a346 GN Netcom Jabra Engage 75 Stereo
    |__ Port 8: Dev 12, If 1, Class=Wireless, Driver=btusb, 12M
        ID 8087:0a2a Intel Corp. Bluetooth wireless interface
    |__ Port 8: Dev 12, If 0, Class=Wireless, Driver=btusb, 12M
        ID 8087:0a2a Intel Corp. Bluetooth wireless interface


#################### inxi -Fxzc0 ########################

System:    Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: UX305UA v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: UX305UA v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: UX305UA.201 date: 10/12/2015 
Battery:   ID-1: BAT0 charge: 47.0 Wh condition: 48.6/56.0 Wh (87%) model: ASUSTeK ASUS Battery 
           status: Not charging 
CPU:       Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake 
           rev: 3 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204 
           Speed: 500 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 4: 500 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting resolution: 
           1: 1920x1080~60Hz 2: 1920x1080 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.1.8 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 
           Device-2: GN Netcom Jabra Engage 75 Stereo type: USB driver: jabra,snd-usb-audio,usbhid 
           bus ID: 1-3:3 
           Device-3: DisplayLink USB3.0 Hub type: USB driver: cdc_ncm,snd-usb-audio 
           bus ID: 2-1.1:3 
           Sound Server: ALSA v: k5.9.1-1-MANJARO 
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 
           IF: wlp2s0 state: down mac: <filter> 
           IF-ID-1: enp0s20f0u1u1i5 state: up speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 534.24 GiB used: 25.05 GiB (4.7%) 
           ID-1: /dev/sda vendor: SK Hynix model: HFS512G39MND-3510A size: 476.94 GiB 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: USB 3.2Gen1 size: 57.30 GiB 
Partition: ID-1: / size: 55.86 GiB used: 25.05 GiB (44.8%) fs: ext4 dev: /dev/sdb2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2600 
Info:      Processes: 238 Uptime: 10m Memory: 7.68 GiB used: 2.44 GiB (31.8%) Init: systemd 
           Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1300 Client: Unknown Client: krunner 
           inxi: 3.1.05 

I would be glad If you could help me with this error because I do not have any troubleshooting experience with AUR packages yet.

Thanks :slightly_smiling_face:

Have you read the pinned comment?

Do you mean " Displaylink is not ready for evdi-1.8.0 yet because of a changed API. […]Use evdi-1.7.0 provided by[…]"? Does this relate to my error?

The AUR package does not seem to have a dependency to evdi-1.8.0 and therefore, I’m not quite sure how this can help me?

*evdi<1.8.0 (evdi-git, evdi-1.7)*
libusb>=1.0.0
*evdi>=1.7.0 (evdi-git, evdi-1.7)*
gawk (make)
grep (grep-git) (make)
wget (wget-git) (make)

Do I have to wait for the next release?

Just tested… works flawless here.

pamac build evdi
pamac build displaylink

maybe

pamac clean --build-files

could help here.

1 Like

The installation over the terminal succeeded. Many thanks. :smiley:

While following this manual to configure displaylink, I’m facing the issue that I’m not able to start the displaylink.service.

See the following output from journalctl -xe:

░░ A start job for unit displaylink.service has begun execution.
░░ 
░░ The job identifier is 48800.
Okt 24 13:43:14 XX-notebook modprobe[3810]: modprobe: FATAL: Module evdi not found in directory /lib/modules/5.9.1-1-MANJARO
Okt 24 13:43:14 XX-notebook systemd[1]: displaylink.service: Control process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ An ExecStartPre= process belonging to unit displaylink.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Okt 24 13:43:14 XX-notebook systemd[1]: displaylink.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ The unit displaylink.service has entered the 'failed' state with result 'exit-code'.
Okt 24 13:43:14 XX-notebook systemd[1]: Failed to start DisplayLink Manager Service.
░░ Subject: A start job for unit displaylink.service has failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support

I’m curios about the line Module evdi not found in directory /lib/modules/5.9.1-1-MANJARO because the directory does exist.

See output from ls /lib/modules/5.9.1-1-MANJARO:

build
extramodules
kernel
kernelbase
modules.alias
modules.alias.bin
modules.builtin
modules.builtin.alias.bin
modules.builtin.bin
modules.builtin.modinfo
modules.dep
modules.dep.bin
modules.devname
modules.order
modules.softdep
modules.symbols
modules.symbols.bin
pkgbase
vmlinuz

I’ve already did a reboot but the error persists.

Output from mhwd:

e[1me[31m> e[m0000:00:02.0 (0300:8086:1916) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

What`s wrong here?

@Seppl

$ pamac search evdi
evdi-git                                               1.8.0.r7.g90e9679-1  AUR 
    kernel module that enables management of multiple
    screens, primarily for DisplayLink USB VGA DVI
    HDMI DisplayPort video git version.
evdi-1.7                                               1.7.0-1              AUR 
    A Linux® kernel module that enables management
    of multiple screens.
evdi                                                   1.7.0-2              AUR 
    A Linux® kernel module that enables management
    of multiple screens.

You need to install the module. :wink: