Display Turns Black If Cursor Moves To Certain Areas (DisplayLink)

Hello there,

I have a strange problem. When I connect my Dell Precision 5570 via a WD22TB4 Thunderbolt Dock and the Display Link to my displays it turns black for a few seconds when I am at one of three possible positions with my cursor (see attached image).
It does not happen on the right side. It happens exactly on the same positions when I connect second display.

My docking station seems authorized when I run boltctl:

❯ boltctl
 ● Dell WD22TB4 Thunderbolt Dock
   ├─ type:          peripheral
   ├─ name:          WD22TB4 Thunderbolt Dock
   ├─ vendor:        Dell
   ├─ uuid:          0d7e8780-00f3-49b4-ffff-ffffffffffff
   ├─ generation:    USB4
   ├─ status:        authorized
   │  ├─ domain:     8bc48780-d063-7dbc-ffff-ffffffffffff
   │  ├─ rx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  ├─ tx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  └─ authflags:  none
   ├─ authorized:    Do 17 Nov 2022 19:34:46 UTC
   ├─ connected:     Do 17 Nov 2022 19:34:45 UTC
   └─ stored:        Mo 14 Nov 2022 07:53:48 UTC
      ├─ policy:     iommu
      └─ key:        no

I thought it might have something to do with “Screen Edges” and turned them off completly, but still no difference

Any ideas on what could be the issue?


Might not be related to the behavior there, but on Desktop Effects.

Thanks, turned that off as well, but no difference. Also I noted that the behavior has something to do with the resolution I choose. If I use lower resolution like 1920*1080 I don’t have that issue.

Is this somehow loggable, so I can see what happens when the screen turns black?