Display not reviving from suspend w/ 5.15, how to allow more than 2 kernels?


Relative newcomer to Arch based systems . . . yesterday I hit the same problem that another user reported of the “display not reviving from suspend, with nvidia card” . . . in their case on a Lenovo, in my case a '12 Mac Pro with Nvidia 780 card. The previous week, all was operational, the problem seems to be happening with kernel 5.15.146-1-MANJARO. Clicking the keyboard the actual computer spins up, but the display remains black. Shut down with the power button.

On restart I selected “Advanced options” in grub and picked the lower choice of kernel, which turned out to be 5.4.266-1-MANJARO . . . and with that kernel the display revives properly!!

I’d like to be able to keep that kernel option available, on the off chance that a pacman upgrade brings in a new kernel, which may or may not work, I’d like to know where in the system I can edit/adjust so that there might be a few more kernels to choose from?? In some of my other linux installs there are as many as 7 or more kernel lines in advanced options, most of them I have not messed with to do that, so some seem to be prgrammed to hold onto kernels. Manjaro seems to be keeping it to one new, and one old???

This problem doesn’t seem to be catching fire over on the other thread, it’s a problem that interferes with regular use of the OS, it “works,” but not entirely. I don’t necessarily want to lock the old kernel in, but I’d just like more “advanced options” in kernels . . . if there is some file to edit, or some way to do that in GUI that would be great.

Thats not how it works.
Different kernels are different packages.
You install and update the different packages separately
(linux61, linux66, etc)

Nope. You decide which kernels to install.
I might guess you started with 5.4, installed 5.15 at some point either by accident or because you were encouraged to … and thats where you are now.

To use the given tool for the job … mhwd-kernel:

sudo mhwd-kernel -i linux61

If for some reason that does not work, you can use the regular package manager:

sudo pacman -Syu linux61

If for whatever reason you need to rebuild initram and update grub
(which in many cases would have been fired upon kernel additions)

sudo mkinitcpio -P
sudo update-grub




OK, thanks for the explanation, so it seems like from what you are saying and the linked page about Kernels,is that I don’t have to worry about pacman removing an old kernel . . . unless I were to run the “rmc” command option while installing a new one??

I think in one of my Manjaro installs I got a Notification on “There is a new kernel available” and I guess it took me to the GUI Kernel handler and I picked a “recommended” kernel, which it now seems to be that on the Mac Pro the newer kernel option isn’t reviving the display.

Your response didn’t exactly add any illumination on whether I should try to jump past the 5.15 options (if there are any) . . . OR just stay with the 5.4 for the rest of the natural life of Manjaro 23.1.3???

The gent who posted with the similar problem to mine said he" tried every kernel up to 6.7" to no avail . . . . I’d like to fix the issue if possible so that the system works with newer kernels the way it does with the olde 5.4 kernel . . . ???

You can try all the kernels you want.
5.4 will be supported for a little under 2 years.
Manjaro is a rolling release system.
There is no ‘life of a release’ - the system lives as long as it is maintained, with no requirements for reinstallation. Technically there is no ‘manjaro release version’ at all, outside of the installation media.

This table reflects LTS (‘long term support’) kernel lifetimes as projected by the linux kernel organization:

Version Released Projected EOL
6.6 2023-10-29 Dec, 2026
6.1 2022-12-11 Dec, 2026
5.15 2021-10-31 Dec, 2026
5.10 2020-12-13 Dec, 2026
5.4 2019-11-24 Dec, 2025
4.19 2018-10-22 Dec, 2024



Please post the output of
inxi -Fazy
because if you followed this tutorial to install legacy nvidia drivers you can’t go higher then 5.10LTS. That would be a good one to install since it will add another year.

1 Like

Thanks for the reply on the topic. I’ll get back to you on that request, booted up in Trixie at the moment. Generally with Nvidia card in linux I’m not using proprietary, because that has led to problems such as I’m experiencing now. But, for Manjaro install, now a couple years back?? I don’t recall there being a question about video drivers to install?? Usually in my other installs I use “nouveau” or “default” . . . but in the case of Leap 15.6 now that did not alleviate the problems either . . . .

Back atcha when I get back over to Mr Manjaro . . . .

So, I haven’t had time to check your link about “legacy drivers” . . . not sure if that applies, as of right now the 5.15 kernel is installed, but I booted in the 5.4 that still appears to be reviving from suspend??

$ inxi -Fazy
  Kernel: 5.4.266-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=/dev/sdb7
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Apple product: MacPro5,1 v: 0.0
    serial: <superuser required> Chassis: type: 7 v: Mac-F221BEC8
    serial: <superuser required>
  Mobo: Apple model: Mac-F221BEC8 serial: <superuser required> UEFI: Apple
    v: date: 07/30/2018
  Info: model: Intel Xeon W3565 bits: 64 type: MT MCP arch: Nehalem level: v2
    built: 2008-10 process: Intel 45nm family: 6 model-id: 0x1A (26) stepping: 5
    microcode: 0x1D
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2276 high: 2689 min/max: 1596/3325 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2073 2: 2689
    3: 2073 4: 2267 5: 2073 6: 2682 7: 2073 8: 2279 bogomips: 51092
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: Split huge pages
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK110 [GeForce GTX 780] vendor: eVga.com. driver: nouveau
    v: kernel non-free: series: 470.xx+ status: legacy-active (EOL~2024-09-xx)
    arch: Kepler code: GKxxx process: TSMC 28nm built: 2012-2018 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 2 speed: 5 GT/s ports:
    active: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 05:00.0
    chip-ID: 10de:1004 class-ID: 0300 temp: 38.0 C
  Display: x11 server: X.Org v: 21.1.10 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 338x270mm (13.31x10.63")
    s-diag: 433mm (17.03")
  Monitor-1: DVI-I-1 model: ViewSonic VA951S serial: <filter> built: 2014
    res: 1280x1024 hz: 60 dpi: 86 gamma: 1.2 size: 376x301mm (14.8x11.85")
    diag: 482mm (19") ratio: 5:4 modes: max: 1280x1024 min: 720x400
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel 82801JI HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:3a3e class-ID: 0403
  Device-2: NVIDIA GK110 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 2 speed: 5 GT/s bus-ID: 05:00.1 chip-ID: 10de:0e1a
    class-ID: 0403
  API: ALSA v: k5.4.266-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Intel 82574L Gigabit Network driver: e1000e v: 3.2.6-k pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 09:00.0 chip-ID: 8086:10f6
    class-ID: 0200
  IF: enp9s0 state: down mac: <filter>
  Device-2: Intel 82574L Gigabit Network driver: e1000e v: 3.2.6-k pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 0a:00.0 chip-ID: 8086:10f6
    class-ID: 0200
  Device-3: Broadcom BCM4322 802.11a/b/g/n Wireless LAN
    vendor: Apple AirPort Extreme driver: wl v: kernel modules: ssb pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 0d:00.0 chip-ID: 14e4:432b class-ID: 0280
  IF: wls5 state: dormant mac: <filter>
  IF-ID-1: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Apple Built-in Bluetooth 2.0+EDR HCI driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-1.1:3 chip-ID: 05ac:8215
    class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 2.73 TiB used: 42.09 GiB (1.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 032 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM010-2EP102
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC43 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD10EZEX-00BN5A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-1: / raw-size: 48.26 GiB size: 47.21 GiB (97.81%) used: 17.75 GiB (37.6%)
    fs: ext4 dev: /dev/sdb7 maj-min: 8:23
  ID-2: /home raw-size: 90.04 GiB size: 88.07 GiB (97.81%)
    used: 24.34 GiB (27.6%) fs: ext4 dev: /dev/sdb10 maj-min: 8:26
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 13.06 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb11 maj-min: 8:27
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 38.0 C
  Fan Speeds (rpm): N/A gpu: nouveau fan: 960
  Processes: 277 Uptime: 4m wakeups: 0 Memory: total: 16 GiB
  available: 15.62 GiB used: 1.48 GiB (9.5%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1363 libs: 461 tools: pamac pm: flatpak pkgs: 0
  Shell: Bash v: 5.2.21 running-in: xfce4-terminal inxi: 3.3.31

No, as you said above, it’s on the free nouveau (like your '09 macbook if I remember correctly) so the link doesn’t apply for your setup. Well, you could still try the 5.10LTS and check if that wakes up since you’d get support until December '26.

1 Like

5.10 is showing as an option in my Mac Pro, not yet installed, and might be a notch before the problematic now installed 5.15 . . . ??

But, yes, also running on my MBP and I checked that yesterday and the kernel is much newer, possibly running 6.7?? In that system I’m using MATE, but on the MP I’m using XFCE, and that hit problems in the 5 series. : - ))

On another thread with somebody having the same problem, there is yet another thread discussing this problem where the user is in XFCE and he said it has something to do with “dbus”??? I just ran a pacman and there was a package with “db” in the name, haven’t checked to see if I can get to “revival” in 5.15.

“Malcolm” over in the other thread said he has tried “all of the kernels and nothing has yet worked for him on it.”

I am at “peace” with it . . . someday my revival from suspend will come, etc. : - )

Yes!! It seems like the 5.10 kernel does revive from suspend, so a bit newer than the 5.4 option . . . and hopefully at some point a patch for dbus will come down the tubes.

1 Like

I inadvertently forgot to select “advanced options” for Manjaro today, so it booted to newest kernel . . . did run a pacman -Syu . . . and then, for “science” I suspended the machine.

A couple minutes later I clicked the keyboard and . . . sllloooowwwwlllyyy . . . the display revived!!! So possibly the patch previously mentioned, did go through.

Over in my Leap 15.6 install, by detectiveing it was found that nouveau had been removed from the modules and had been blacklisted by nvidia, but then nvidia wasn’t exactly online either . . . . In the case of Manjaro checking lsmod shows nouveau in all of the right places . . . so seems like a different causative factor?

$ uname -r

I’ll monitor Manjaro for a bit more, before marking it as solved . . . but seems like it probably is.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.