Display manager not launching after rebooting with nvidia drivers installed

hey all, so i just got a new laptop with a dual nvidia and intel gpu, and i have never dealt with this kind of setup before. i went to install nvidia drivers and after restarting to load the optimus daemon i got stuck on a fsck screen. after some digging i tried to tty into ny computer and sure enough it launched, so its a display manager issue, but all solutions ive cone across involve uninstalling unused display drivers which sounded like a good idea until i used mhwd -li and found nothing but my hybrid driver and the video-modesetting driver which i admittedly have no idea the purpose of.

ive never tried to run any linux distro, much less manjaro on nvidia hardware before so im honestly lost on what to do, ill send a photo of my installed drivers and neofetch as soon as i can find a way for the forum to let me, and will be more than willing to supply any needed information for troubleshooting. thanks in advance!


Hi there,

How exactly did you attempt to do this?

i used the gui mwhd tool and then installed optimus manager from the aur. after that i started the daemon with systemctl from the terminal and restarted

now here we are

Do you have any particular reason to do that?
PRIME already handles switchable graphics fine.



glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

And … well, OM, in particular is a largely uneccesary, and somewhat hacky utility.
If you really need it, then you need to follow their instructions to augment system files:

(though, again, I recommend avoiding it altogether, unless you really need to disable one GPU or the other between boots, and for some reason OM is the only option)

fair enough, i was just following a guide i found haha. how would i go about removing it at this point? im afraid to day ive used debian based distros for most of my time so i dont know pacman very well, also would i be able to uninstall it from tty?

Maybe see this, in case you need it:
[HowTo] Resolve an unbootable Manjaro (black screen, login failed, cant boot, etc)

It slightly depends which packages you installed exactly.
You can check with:

pacman -Qs optimus-manager

But I will assume you wanted a GUI/Tray thing, and since you are on KDE, I will assume you got the optimus-manager-qt package. So a removal, including all dependencies no longer required, and extra save files, would look like this:

sudo pacman -Rns optimus-manager-qt

If you installed other packages too or made any other manual changes to system configuration files, or other such things, you will have to handle that as well of course. Reference your original guide.

PS: You can also reboot from tty using:

systemctl reboot

PPS: These things might be helpful to you:

awesome, thank you for the help. ill try this out in a bit and see how it works out, check back in in a bit

that did it! thank you so much!

Glad its sorted.
Do take a peak at the wiki for an introduction to PRIME.
Really the gist of the thing is to let the default iGPU run most of the time, then if you need to do 3D rendering, or play a AAA game then invoke prime-run to launch it using the dGPU.

Note: To use steam as an example, because it is slightly special… Rather than launching steam itself that way, set game launch options to (assuming no other options):

prime-run %command%

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.