Display manager doesn't start after newest Manjaro update

Well … sorta …

The ‘splash’ removal was supposed to stop plymouth from running.
But then

(plymouth is the fancy boot splash that mainly exists as bloat, but sometimes as a boot breaker … especially if one has missed kernel-mode-setting, or pacnews in general, but sometimes just because it feels like it)

If it were the same issue as previously experienced by users en-masse a bit ago, then you probably do have missing pacnews and/or unconfigured kms … but also you could probably continue avoiding that by doing your upgrades again while allowing downgrade (spotfix for previously mentioned plymouth fallout)

sudo pacman -Syuu

Of course my 100% honest opinion is that you should kill it with fire permanently.

You only see this lanes that told you that everything is okay… but you still dont have a desktop?

I just have a screen full of similar lines, nothing else is happening

If it continued then the final messages may be helpful.

If it stopped where you quoted then it might still be plymouth somehow.

When its again Plymouth i think he needs to finally kill it?

Im out of clue at this point…

I think he told me in this topic (above) his install was from 11/2023…

Would be strange if he had a pacnew file already from a relative fresh installation.

There are the last lines on my screen right now.

Will running this in tty kill it? or is it “sudo pacman -Syuu” as @cscs has said?

I edited my posting… i think there are better options.

The -Syuu should fix the previous plymouth issue.
The link has a guide for fully removing plymouth if thats what you want to do.

1 Like

Another option is to add this stuff into your grub lane, where you removed Splash earlier.

If you have a nvidia GPU in your PC.

1 Like

I did the -Syuu and it updated some packages but when i boot my pc i still get a bunch of lines of code the last one of which is “Starting Terminate Plymouth Boot Screen”

So what I should do is remove Plymouth completely and maybe add

as an extra line in the glub lane.

Thank you so much for your help guys despite my stupid questions. I will try to get rid of Plymouth completely using the linked guides!

Do you have a nvidia graphics card?

Yes I do!

sudo nano /etc/default/grub

only add this nvidia_drm.modeset=1 nvidia_drm.fbdev=1 to the this line below:

GRUB_CMDLINE_LINUX_DEFAULT=

With crtl+O and enter (you save the file) and exit with crtl+x

And after you done just this command:

sudo grub-mkconfig -o /boot/grub/grub.cfg

After a restart you see the result.

Its possible that nvidia_drm.modeset=1 is already enough… and you can add the other command after another restart when its not working.

1 Like

Just to confirm, do i add it to look like this?

GRUB_CMDLINE_LINUX_DEFAULT=“nvidia_drm.modeset=1 quiet udev.log_priority=3”
and then maybe nvidia_drm.fbdev=1

it is just that there are other things inside the " " after GRUB_CMDLINE_LINUX_DEFAULT= does the order matter?

Yeah i know, there are other commands your your “Individual system” thats why i wrote ADD.

Your example looks good. The order don’t matter as far as i know… at least i added and replaced in my history differend commands there and never saw a difference with the order.

Hey! Did you know? There’s an NVIDIA wiki with all the answers! Wow! Isn’t that cool? :sunglasses: :hushed:

https://wiki.archlinux.org/title/NVIDIA

Don’t worry, you are free to ask questions along the way during your learning experience. :grinning:

1 Like

The problem is that this wiki’s are not really userfriendly for beginners/noobs.

Alot early steps and steps between are not explained.

Whoosh! Right over his head. :wind_face: :leaves:

The great thing about wiki’s is they’re community maintantained. You are the community. You can help improve it. :wink:

…and I’m out. :wave:

1 Like

Thank you for clarifying! I did

I still get the same screen with a bunch of [ ok ]'s and the “starting Terminate Plymouth Boot screen …” line.

And you have Kernel 6.6 also installed and removed Kernel 6.5?

With Kernel 6.6 and this changes it should work… atleast alot Forum User could boot after that changes… uufff