Display freezing where system continues to run

  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
    

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m an editor here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. Have you tried any of the LTS kernels already? (5.4 LTS would be my first port of call seeing the AMD Radeon R9 Fury was released in 2015 and 5.10 LTS would be my next port of call if 5.4 doesn’t work)
    If you’re asking yourself Why?, you should read this (especially the “Linux has multiple kernels” subsection).

:crossed_fingers:

2 Likes

Hello. Neither the 5.4 or 5.10 kernel solved the problem.

  • Have you tried creating a new user and logging in there yet? (E.G. abuttandahalf2)
  • How do you restart?
    • sudo reboot
    • REISUB
    • Something else?

:thinking:

Did you try 5.11.18-1?
Worked for me.

5.11.18-1 didn’t solve the problem unfortunately.

When I’m forced to restart I just hold the power button. Usually I use reboot

Please read this:

because:

actually makes your problem worse!

:sob:

I tried to use REISUB once when I encountered a hard freeze and I think it didn’t work. Now I don’t encounter hard freezes because I don’t try to enter the graphical environment (ctrl + alt + F7) after a freeze without restarting lightdm. I don’t think it would be useful to induce a hard freeze and then REISUB.

Edit: I enabled SysRq and the next time I got a freeze I went to tty4 and then back to tty7. This cause the computer to be unresponsive. I pressed alt + SysRq and then alt + r, e and lightdm was restarted and I could log in again. This will be useful in the future. Thanks.

2 Likes

:grin: :+1:

2 Likes

Going through the same same issue on my folio 9480M. One is forced to just restart. Unfortunately haven’t had any help so far. Makes me to really want to move away from manjaro for now. You never know, you could be doing a presentation and the screen freezes!

1 Like

I’m in the same boat. I’m looking at other distros because I can’t have my computer freeze every half an hour. It doesn’t seem like this problem is going to be solved.

I’ve been having the same issue with my Intel NUC for a while now.
Haven’t figured out how to fix the issue.

To be able to help anyone having this issue, what we need is:

  • a REISUB
  • A journalctl --system --boot=-1 --priority=3 | tail --lines=35

As that will tell us the last 35 system events that happened on the system during the previous boot -1)

:man_shrugging:

I came across this thread because I having two different lock up issues, with a new box I’m setting up.

First one is that when the Lock Screen is enabled and the dialog that comes up says ‘Unlock’ it does not matter what I enter the display never unlocks and I have to power down with the power button.
Isn’t the ‘Unlock’ password they same as the account’s ‘Loging’ password? If not where does the ‘Unlock’ password get set?

Second issue: This box has a lot of USB3.x ports so I plugged the keyboard into one and the mouse into another. I would get random complete system freeze ups when the mouse or keyboard were in use. If they were untouched the system would not freeze up. I moved both the mouse and keyboard to external USB 2.0 hub and have not had that type of lockup since. The advice to enable SysRq is not helpful here because it is the keyboard that stopped functioning. I’m guessing there is a USB 3.x driver issue going on here?

On my old Manjaro box Grub came up and asked me which Kernel I wanted to run.
This one is not doing that, where do I enable it?
Also is there a place to enable seeing the Linux boot spew in a console at power up?

System:
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=8935559e-64f9-40ea-83f2-140032fca11e rw sysrq_always_enabled=1
  quiet
  cryptdevice=UUID=4a080333-8c2f-4d10-945b-a1cfcee62c42:luks-4a080333-8c2f-4d10-945b-a1cfcee62c42
  root=/dev/mapper/luks-4a080333-8c2f-4d10-945b-a1cfcee62c42
  resume=/dev/mapper/luks-ba131c0b-2465-4366-81dd-6a95708cfa50
  udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
  vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: BESSTAR TECH LIMITED model: HM80 serial: N/A
  UEFI: American Megatrends v: 5.16 date: 07/09/2021
CPU:
  Info: 8-Core model: AMD Ryzen 7 4800U with Radeon Graphics socket: FP6
  bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96)
  stepping: 1 microcode: 8600106 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 57504
  Speed: 1397 MHz min/max: 1400/1800 MHz base/boost: 1800/4300
  boost: enabled volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 1: 1397
  2: 1397 3: 1396 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1397
  11: 1397 12: 1397 13: 1395 14: 1397 15: 1397 16: 1397
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel bus-ID: 06:00.0
  chip-ID: 1002:1636 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver:
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2")
  s-diag: 1055mm (41.5")
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.2-2-MANJARO LLVM 13.0.0)
  v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:
  Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 06:00.1
  chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
  driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x
  bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Realtek driver: snd_hda_intel
  v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: JMTek LLC. USB PnP Audio Device type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4.3:7
  chip-ID: 0c76:161f class-ID: 0300
  Device-5: C-Media Audio Adapter (Unitek Y-247A) type: USB
  driver: cmedia_hs100b,snd-usb-audio,usbhid bus-ID: 5-3:2
  chip-ID: 0d8c:0014 class-ID: 0300
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169 v: kernel port: f000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 03:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-3: Intel Ethernet I225-V driver: igc v: kernel port: N/A
  bus-ID: 04:00.0 chip-ID: 8086:15f3 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 5-4:3 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 4.1 TiB used: 20.56 GiB (0.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-A02
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B
  speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFK52.9
  temp: 30.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 4TB
  size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 1B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 442.78 GiB size: 434.76 GiB (98.19%)
  used: 20.56 GiB (4.7%) fs: ext4 block-size: 4096 B dev: /dev/dm-0
  maj-min: 254:0 mapped: luks-4a080333-8c2f-4d10-945b-a1cfcee62c42
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 440 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
  maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 33.86 GiB used: 0 KiB (0.0%)
  priority: -2 dev: /dev/dm-1 maj-min: 254:1
  mapped: luks-ba131c0b-2465-4366-81dd-6a95708cfa50
Sensors:
  Message: No sensor data found. Is lm-sensors configured?
Info:
  Processes: 375 Uptime: 23m wakeups: 0 Memory: 30.84 GiB
  used: 2.99 GiB (9.7%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: N/A Packages: pacman: 1370 lib: 348 Shell: Bash (su) v: 5.1.8
  running-in: xfce4-terminal inxi: 3.3.08

Have you tried any of the troubleshooting in this thread already?

:thinking:

I have enabled SysRq.

I have installed Kernel LTS 5.10 and it is running now, after searching for what I needed to edit in Grub and where. It is nice there is a GUI to install the Kernels. If there is a GUI to set which one is active I’m missing it?

I have installed the XScreen saver and so far the ‘Unlock’ issue has not come up.

Note that when the ‘Unlock’ lockup happens, the system is still running as I can get in with SSH. It is just the key presses are ignored. When the USB 3.x Keyboard/Mouse lockup happens, the system is DEAD.

I have moved the keyboard back to the USB 3.x port while running LTS 5.10. So far no lockup. If I can run for a few hours this way, I’ll try moving the mouse to USB 3.x too and see what happens. I’ve already run longer than I have in the past with the Keyboard on 3.x.

There is also a difference worth noting is that when the 3.x lock up was happening I was connecting with WiFi. Now I’ve got the hardwired Ethernet running and WiFi turned off.

I know changing multiple things at once is muddling the debugging.

1 Like

My apologies for the late reply: New job… :frowning:

I’m an old fart old-fasioned so I don’t even know which GUI would tell you that, but:

uname --kernel-release

gives you that answer…

Did all of your changes help and does it run stably now???

:four_leaf_clover:

I have been unable to reproduce the lockups on my current set up,
despite trying extensively with different USB connections and Kernels.

Only thing different is a different monitor that I can’t replicate here.

I’m still inclined to believe the problem being Keyboard and Mouse on USB3.x,
as as soon as I moved them to a 2.0 Hub the lockups stopped.

Actually no.
I know what uname does.

What I’m saying is there is a Manjaro GUI that lets you install different Kernels, great
However there is nothing that tells the system which of those Kernel to run, other than rebuilding Grub at the command line, then picking that one at boot from the Grub menu.

The Kernel GUI installer should give to option to rebuild Grub and select which one to use on the next boot.

1 Like