Display and Repository issues

Hi all. Fresh install of manjaro. Display is only working on my 2nd monitor, my main monitor is showing no signal and the system is not seeing it. I reckon i need to install the AMD propriatory drivers, but I cant do this as pacaur will not install due to auracle not installing because

Error: python-more-itertools: signature from "Kyle Keen <keenerd@gmail.com>" is marginal trust
Error: Failed to commit transaction: invalid or corrupted package

Doing pacman syu also gives errors: error: failed to prepare transaction (could not satisfy dependencies)

:: installing smbclient (4.15.2-1) breaks dependency 'smbclient>=4.17.5' required by samba

Being a fresh install I really am not sure what could be wrong with it… I had to downgrade to 5.15 kernal from 6.1 as the broadcom driver did not work with kernal 6. All the other issues remained the same despite going back to kernal 5

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Welcome to the forum! :wave:

You are in an unusupported partial upgrade state. Please see Pacman-mirrors - Manjaro

There aren’t any. The open source driver is installed automatically.

If the issue still persists after performing a full update as mentioned above, please create a new Graphics & Display topic. One issue per topic, please.

Please see the following for more info. Note that I’ve edited your post to make it readable with proper formatting.

Im sorry about the formatting, you’ve lost me though slightly… You say perform an update as above, do you mean perform a pacman update or full system update? Ive tried the full update (Syu etc) but to no avail. Sorry for being a bit thick but could you say fairly well what i need to put into terminal? Not used linux for a couple of years so a bit rusty!


… Ah, but have you tried the command hiding in plain sight behind this link I posted? :point_down: :wink:

After reading it again… Its now found 1600mb of updates! Sorry, i’m being slow tonight I thought it was just telling me to run Syu! Hopefully that fixes it. Do you mind explaining a little about what has actually happened to make this whole thing do this? I can kind of understand it if its because of downgrading the kernal, but it was doing it before that. I would have thought that off of a fresh install off of a fresh ISO downloaded days ago it would be all fresh and up to date? Thanks again.

Your mirrors were out of date. The command updated your mirror list and fetched the most recent updates.

FYI, that’s not actually a downgrade. Manjaro allows multiple kernels installed at the same time. Both 5.15 and 6.1 are LTS (Long Term Support) kernels, so either are a fine choice depending on which works the best with your hardware. I keep three kernels installed. Right now I have 5.15, 6.1 & 6.2 installed.

1 Like

Well… still not working!

Building auracle-git...
==> Making package: auracle-git r366.8739929-5 (Fri 14 Apr 2023 00:12:07 BST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating auracle git repo...
  -> Found 0001-Force-fmt-dependency-to-static.patch
  -> Found 0002-Update-abseil-cpp-to-LTS-20220623.0.patch
  -> Found 0003-Use-non-deprecated-meson-command.patch
==> Validating source files with b2sums...
    auracle ... Skipped
    0001-Force-fmt-dependency-to-static.patch ... Passed
    0002-Update-abseil-cpp-to-LTS-20220623.0.patch ... Passed
    0003-Use-non-deprecated-meson-command.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of auracle git repo...
Cloning into 'auracle'...
==> Starting prepare()...
  -> Applying patch 0001-Force-fmt-dependency-to-static.patch
/var/tmp/pamac-build-james/auracle-git/PKGBUILD: line 38: patch: command not found
==> ERROR: A failure occurred in prepare().

Is the output from trying to install pacaur “pamac install pacaur”

You’re missing the prerequisites for using the AUR.

Please see:

Are you sure?

Auracle is fine, I guess. However, I do not recommend Pacaur. Please see AUR helpers - ArchWiki

FYI, Pamac is also an AUR helper, there’s no need to install another one. However, we do have yay in the community repository if you prefer.

OK I will endeavour to use yay instead. only wanting pacaur as its what i always used to use. I am still only getting output on one display and it is still only registering one display, from the VGA output. Nothing over HDMI. Any ideas? I was wanting to install the mesa drivers for AMD but you reckon that isnt needed? and yes, that is definitely the output from that command. I copy pasted it direct

Ah, I see. pacaur depends on auracle. An AUR helper should not need another AUR helper to work. :man_facepalming: