Disk activity 10 minutes after startup

I am running Linux Manjaro with kernel 15.5.6-2

Just after the update of Quonos, I have experienced the following:

At startup, after 10 minutes or so, the disk will churn and control is lost for a few minutes. Then all is well. This recurs with every warm or cold boot.

I am concerned that if I restore I may lose things like my calendar updates, email files (but I have that backed up), etc. Who know what else? It may not even solve the problem. But then it might.I have my main datafiles stored on a second partition with aliases on the startup partition pointing to the folders on the second partition.

If I just turn the computer on and leave it running all day, the problem only happens once, so I can live with it. But shouldn’t have to.

Suggestions please. Please also consider that my technical knowledge of Linux is minimal at best.

Thank you.

How you have the backup of files? Have you tried booting into older kernel and seeing if its just a problem with the kernel (I load other kernels through grub but maybe there is youtube video on how to load a different way)?

Welcome to the forum!

The thing is, GNU/Linux is a UNIX operating system, and UNIX was designed to be running 24/7. It does a lot of things in the background while it’s idle, and it also executes a number of scheduled maintenance tasks at night, when the system is expected to be least busy.

Now, if you don’t keep the machine running 24/7, then those scheduled tasks cannot be executed at the planned time, which is why the system will then execute all of the missed maintenance tasks at boot time. This can then indeed result in lots of disk I/O, and it is this intensive I/O which diminishes the response of the system to user input, depending on your hardware specs.

I used Timeshift to backup the system. I have tried older kernels (boot with shift key down) and have the same results.

Interesting. How do I determine if that is what is going on? If it is, how do I reschedule it for a more convenient time?

By looking at your process list and seeing what’s consuming CPU cycles. :wink:

But you can rest assured that it’ll probably be that. You’re not the first one to report this sort of thing. :wink:

By modifying the cron jobs and/or the systemd timers. But if you have to ask, then it’s not for you. :wink:

Some “light” reading on scheduling… :arrow_down:

man crontab

For example with htop you could see what your PC is doing

pamac install htop


Additional information: I don’t know what desktop environment you’re using ─ you didn’t tell us ─ but if you’re running Plasma, then chances are that it’s just Baloo indexing your files.

You can disable Baloo, or tell it to only index the files but not their content, and/or exclude certain directories from being indexed. :arrow_down:

I am using xcfe

Well, it was a possibility. But what I said earlier still stands, though. It’s just that if you’re using Plasma, then Baloo exacerbates the problem.

I have been told to emphasize that my problem started just after the update of Quonos, it was not happening prior to that. And that the system is locking up. Also that I have an M.2 NVME SSD with two partions, the first of which is where booting into Manjaro takes place. And that I have an Intel 10600K Processor which is pretty fast.

You have also been advised ─ by two people on this thread ─ to look at the list of processes in order to see which process is eating up your CPU cycles.

Beating around the bush isn’t going to help you, nor anyone else here who might be having the same problem as you. If you want this resolved, then you’re going to have to provide us with data we can use.


I switched to the kernel labelled 5.10.83-1 LTS and for several hours my problem did not recur.

Eventually I switched back to the kernel labelled 5.15.6-2 and the problem soon appeared.

With Htop I was able to see some processes each using over 70% of the CPU:

Simplenote - this went away if I quit the program.

Vivaldi enable-crashpad - this did not go away if I quit the program but eventually stopped requiring as much CPU.

Later I saw tracker-miner-fs-3 using large cpu.

Some useful information at the link below on how to tweak that.


Thank you. I now have done this and will monitor.

I tried this but the tracker came back.

Disabling tracker for your user only

Enter the directory ~/.config/autostart, create it if it does not exist
Create a file named trackerd.desktop
Paste the following into the file, save and exit:

[Desktop Entry]

So I have now tried it and will see if that helps.

I wouldnt do it that way…
But also that service comes from tracker3-miners package, which is from Gnome DE while you use XFCE … so why do you have it?

pactree -r tracker3-miners

I guess something I installed used it. Maybe Gnome Calendar. Not sure.

Sorry but what does your command do?
Terminal responded: tracker3-miners

It should show anything that requires it … like this example:

pactree -r mhwd-nvidia


If yours returns nothing … then you have that for no reason and you can safely remove it if you dont use its functions.