Discord ignoring default applications; want's to open everything with firefox

Upon install originally discord would open files with the associated default program (e.g. image viewer for images (this behavior is imo even better than on windows lol) and default browser (Chromium) for links)

Then I installed firefox, it’s not set as default for anything in the system settings (on kde) but now discord just wants to open everything with it.

Hi @rabcor ,

I wonder whether you could consider to install lightcord instead of discord. Pretty much the same interface an independent from the browser. Neat stuff.

Hope this help, regards

1 Like

@j8a idk lightcord looks a bit shady to me. The sheer amount of shit it’s devs are getting is unbelievable, and I don’t think they’re gonna keep the project going for very long, or maybe they’ll just do what all the haters are saying about it and turn itinto a virus or something.

Doesn’t look like a stable project to me; nevermind that it’s like what version 0.1 and has only been in development for 1 year?

It does strike me as odd though how ridiculously much the project gets shit on… But I don’t feel like touching this with a 10 foot pole right now. Seems like a recipe for things going wrong anyways.

Default applications are saved here: ~/.config/mimeapps.list Change it.
Or re-enable it on the settings…

~/.config/mimeapps.list looks correctly configured though. Only mention of firefox in the file is a removal of firefox as an associated application for one filetype.

what’s the output of

pamac search discord | grep Installed

because that sounds like a snap, flatpack or similar crap erm… garbage? :grin:

1 Like

Output is:

$ pamac search discord | grep Installed
discord                                        [Installed] 0.0.15-1   community 

Also tried deleting user config files with: rm -rf ~/.config/discord

Did not affect the issue.

Update: I managed to solve the issue of it always opening things in the wrong browser, simply went to kde’s default applications menu, set firefox as default, then set chromium as default again, it now opens everything in the correct browser…

But it hasn’t gone back to it’s behavior of opening images and such in my image viewer :frowning:


That looks good, so if you don’t get a satisfactory answer by anyone here in the community in the next few days, please read this:

Especially the What’s this Upstream / Downstream business??? and then file a bug upstream…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.