Discord hangs entire PC

For most of the time Discord behaves normal but sometimes it hangs my entire PC and It’s lag that much that I can’t even login in terminal mode ( CTRL ALT F2). I was able to log in once and using htop command I saw pulseaudio and discord processes eating my entire cpu with discord (pulseaudio more). What happened and how to solve it?

Specs if its important:
Z270 PC MATE ; Pentium G4560 ; Intel HD Graphics 610 ; 8GB RAM ; NVME 250GB
linux57.17-2 ; xorg-session

hello t0ssox,
is it the same if you open Discord in the browser?

No. I don’t have any problems when I’m using discord in browser (In brave browser which is based on chromium, discord is a electron app so its based on chromium too)

Same Problem here using XFCE. Since discord is proprietary, i have no idea how to fix this. I guess hardware acceleration is not working (correctly).

Disabling hardware acceleration in Discord didn’t help I think. Maybe there is no more frequent crashes like before disabling or its only a placebo.

I’ve read of a few people having trouble with the discord app apparently the snap and flatpak versions are giving less issues

1 Like

Thanks. My son’s been complaining about exactly this problem with Discord installed from the AUR. I can certainly try either the snap or the flatpak version to see if it makes a difference. Hadn’t thought of that!

Or you could try an alternative client like lightcord. Bear in mind though that this is disliked by discord, but gives the best chance of having a different result.


I will give it a try, hope voice chat works also since it says on the page:

This is a complete Discord Client. That means it has his own .exe and does not require the original Discord, plus it can’t break when there’s a new update.

Holy $*&^ I thought I was one of the only people experiencing this issue. Like Megavolt, I’m using XFCE and this morning at work, I tried (twice) to run Discord and everytime it brought my workstation to a grinding halt; Spotify stopped playing music, Chromium froze, etc. Here’s the output from “inxi -b” for me:

System: Host: Fawkes1 Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.3 Distro: Manjaro Linux
Machine: Type: Desktop System: Dell product: Precision 5820 Tower X-Series v: N/A serial: <superuser/root required>
Mobo: Dell model: 0X75JG v: A00 serial: <superuser/root required> UEFI [Legacy]: Dell v: 2.4.0 date: 07/06/2020
CPU: Info: 10-Core Intel Core i9-10900X [MT MCP] speed: 1200 MHz min/max: 1200/4600 MHz
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon Pro WX 7100] driver: amdgpu v: kernel
Display: x11 server: X_Org 1.20.10 driver: amdgpu,ati unloaded: modesetting resolution: 1: 1680x1050~60Hz
2: 3840x1600~60Hz
OpenGL: renderer: AMD Radeon Pro WX 7100 Graphics (POLARIS10 DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0)
v: 4.6 Mesa 20.2.3
Network: Device-1: Intel Ethernet I219-LM driver: e1000e
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
Drives: Local Storage: total: 942.70 GiB used: 325.94 GiB (34.6%)
Info: Processes: 479 Uptime: 8d 22h 08m Memory: 15.36 GiB used: 8.89 GiB (57.9%) Shell: Bash inxi: 3.1.08

Despite the uptime, everytime runs fluid. So it’s no an uptime issue (at least for me). Like I said, everything runs liquid smooth. It’s only when I launch Discord and (what’s his name) Claude (?) (The Discord icon’s name) does his spinning that the entire machine just comes grinding to a halt. I’m half tempted to run fiddler and see what the hell it’s doing but I’ve debugged so many other developers stuff (gaming at home) lately, that I just don’t have the energy to try to debug yet another other-developer thing.

EDIT 1 (12/18/2020 8:44:11 AM ET): Formatting

EDIT 2 (12/18/2020 8:45:24 AM ET): Just tried to run Discord again (third time this morning), and it actually came right up… No idea wtf it was doing before, but it seems fine now shrugs