Discord does not have a notification badge in the Manjaro KDE

Hi,

Discord has a unread notification badge that displays on top of the discord icon in the taskbar/task manager. On Kubuntu, I would see the badge whenever I had unread notifications but on Manjaro KDE I haven’t been able to get it to work. I’ve tried both regular and canary versions of Discord and neither have worked. I haven’t seen the notification badge on a single version of Plasma since I started using Manjaro which I believe was Plasma 5.18.

I am using the most up-to-date version of Discord Canary along with Plasma 5.20.4. Is there something that needs to be specifically installed to get these badges to work?

Thanks.

In System Settings

Personalization → Notifications → Applications: Configure :arrow_down:

For some reason Discord doesn’t appear in my applications list. Is there a way to add it to the list?

image

Did you install Discord from either the Community repository or the AUR? If not, then it won’t be integrated with the system.

Seems like Discord-canary doesn’t appear even though it’s installed from the AUR but normal Discord does. After installing regular Discord from AUR and ensuring all the notifications settings were enabled, badges still don’t appear in my task manager unfortunately.

Notification badges work for programs like Arkegator, Dolphin and Firefox so this may be a Discord issue.

Well, I have the regular Discord from the community repo and for me it works, albeit that I’m not currently using Discord anymore.

Do however keep in mind that it’s an Electron application and that it is GTK-based, so it will never fully integrate with Plasma ─ read: give you finer control over the notifications ─ the way KDE/Qt applications do.

Very strange. I just checked and apparently my Discord is also from community and not AUR so I’m not sure what could be different between yours and mine. Seems like there’s a few other people reporting issues on reddit with Manjaro and the unread badge indicator. I’ll keep looking around. Thanks for your help.

1 Like

Just wanted to update this thread as I found a fix to this issue. Installing the libunity package from the AUR restored the notification badge for me. It was a little bit of a hassle to get installed but has been working without a problem since.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.