Discord cannot transmit my voice without headphones

Hi i had a issue. Thanks to God it solved itself but it gave a another issue. Issue is it cannot tranmit my voice when i plug off my headphone (JBL Quantum 100). And annoying part is zoom can transmit when i plugg off my headphone.

What must i do ???

Here is my info(s):

[huso@LenovoIP320 ~]$ inxi -Faz
  Kernel: 5.11.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=6a44b7ec-e1fa-4a86-af21-cad77fd33bc6 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Cinnamon 4.8.6 tk: GTK 3.24.27 vt: 7 dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 81BG v: Lenovo ideapad 320-15IKB 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 320-15IKB 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40679 WIN serial: <filter> 
  UEFI: LENOVO v: 6JCN14WW date: 09/28/2017 
  ID-1: BAT0 charge: 12.6 Wh (100.0%) condition: 12.6/30.0 Wh (42.0%) 
  volts: 8.3 min: 7.5 model: SMP L16M2PB1 type: Li-poly serial: <filter> 
  status: Full 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: E0 cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 700 2: 1958 
  3: 1612 4: 825 5: 759 6: 700 7: 787 8: 748 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: nvidia 
  v: 460.56 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1d10 
  class-ID: 0302 
  Device-3: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:7 
  chip-ID: 174f:241a class-ID: 0e02 
  Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting,nvidia 
  alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.6-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 8086:3166 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-7:5 chip-ID: 8087:0a2a class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 1.82 TiB used: 425.79 GiB (22.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4B6Q scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate 
  model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 512 B 
  logical: 512 B rotation: 5400 rpm serial: <filter> rev: 1.14 scheme: GPT 
  ID-1: / raw-size: 110.35 GiB size: 108.06 GiB (97.92%) 
  used: 22.63 GiB (20.9%) fs: ext4 dev: /dev/sda6 maj-min: 8:6 
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) 
  used: 28.7 MiB (11.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 265 Uptime: 28m wakeups: 74 Memory: 7.56 GiB 
  used: 2.23 GiB (29.4%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1504 lib: 465 flatpak: 0 
  Shell: Bash v: 5.1.0 running-in: gnome-terminal inxi: 3.3.03 
[huso@LenovoIP320 ~]$ 


[huso@LenovoIP320 ~]$ sudo alsa-info.sh --upload
[sudo] password for huso: 
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at [http://alsa-project.org/db/?f=268c8bd4bef3c5086c838d20d494c825aafc4dfd]
Please inform the person helping you.

[huso@LenovoIP320 ~]$

Hello @FanOfLinux :wink:

So you just detach the mic and put it into the jack right?

Do you have discord and zoom active at the same time? There is a restriction, that you can only use one application and one hardware mic input at the same time. It is bound for the active program and cannot be used for any other program during this time.

Here is an example how you could loop or remap the mic or speaker so that you can use them on different applications at the same time:

Nope. I use my atachable mic when i use my headphones and it (mic) does not fit my notebook’s jack because mic’s jack atachable for only headphone. Mic’s jack is so small to atach notebook.

I don’t speak zoom and discord at the same time. If i open my sound on zoom i close my sound at discord. Second thing is Discord still cannot transmit my sound when i close zoom. Thrid thing is if i change my mic at discord on record, record sound get earrapey (or we can say VERY VERY LOUD).

Btw thanks for kind response :slight_smile:

Heres’s my sound settings:

1 Like

@FanOfLinux Please check also under pavucontrol at the Recording Tap if “Internal Audio” is selected and not “Monitor of Internal Audio”, which would be the desktop sound. Sometimes that happens also… when you re-pluggin something or you bound your HW Mic to a new program. It resets just to default.

Also under “Input Devices”, there must be the correct Port set. If the wrong one is set, and that happens sometimes at least on my setup, then you must set it again. But normally it chooses the plugged in one automatically.

Possible that discord is running in the background? So that you close it to taskbar (indicator-bar) ?

I checked:

Monitor of Dahili Ses Analog Stereo= Monitor of Internal Sound Analog Stereo
Dahili Ses Analog Stereo= Internal Sound Stereo (It choosed this)


Monitor of Dahili Ses Analog Stereo= Monitor of Internal Sound Analog Stereo
Dahili Ses Analog Stereo= Internal Sound Stereo
It setted internal mic. and sound level is %15. If i increase it, the sound is so loud

I looked at indicator-bar and task manager. Both of them hasn’t it.

Why god? What did i do to deserve this? :frowning:

Here is ALSA settings:


Ekran Görüntüsü - 2021-04-05 14-53-05




Oh my god. I made a big sin. :laughing:

Did you try disabling auto-mute at alsa? Maybe the threshold is just to high and therefore you need to make it louder. However i guess it is more a problem of the gain level…

Now you have to recite 10 holy Linux commands, change your profile picture and never do it again. The sacred shell will forgive you. :stuck_out_tongue:

It did not work :frowning:

Oh no i know 5 commands :open_mouth:

Then recite all commands in ls /bin … to make sure that no command is discriminated. :smiley:

:pray:t4: :pray:t4: :pray:t4:

So… this problem never solve :frowning:

Only happens with discord? Try maybe lightcord…