Disallow a display from being used

I have an HDMI audio device, and every-time I open a new window most windows start on it. There’s no display out from this device. So i have to right click it in taskbar, move then bring it over…
Anyway to make XFCE ignore a display device? Anyway to make windows open at cursor?

Does the device show up in the Display settings?

Yes, I keep moving it to the far right and setting my main monitor as main display but on boot it’s resetting to the middle and overlapping on my right monitor.
If you disable the display there is no audio out.

I don’t find anything close to your issue, so i can only give suggestions.

  • Does your device still shows up in pavucontrol if the (fake) display is disabled?
  • Have you tried defining a display profile in order to pin display locations?

Every time I boot it randomly moves all my display devices around and the audio receiver is usually over another monitor…
I don’t have media or link privileges :confused:

Configuring a display profile should work around that.

In your display settings, set up your monitors to the way you want them to be, then use a tool such as arandr to generate a script that will set your monitors to the way they are configured now, and set that script to autostart.

You can install arandr with the following command:

sudo pacman -S arandr