Disabling kwin compositor causes screen to go a permanent black

Hello, when I disable the compositor, whether through the use of Shift+Alt+F12 or when a fullscreen application disables it (which I have now turned off.)
The entire screen goes black (both monitors) apart from a slight slither at the bottom.
I do not know the cause nor any fixes, help would be greatly appreciated.

Kwin isnt just a compositor, its also a window manager. Window managers provide the desktop. It isnt surprising everything went black when you turned it off. The fix is simply dont turn it off.

Turning off the compositor shouldn’t make everything black. You simply lose effects and animations.

What is your system info, including the version of KDE?

Sure, inxi -v 3 is.

  Host: deciet Kernel: 6.0.11-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 Desktop: KDE Plasma v: 5.26.4 Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: Z170-E v: Rev 1.xx
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 3301
    date: 01/13/2017
  Info: quad core model: Intel Core i5-6600K bits: 64 type: MCP
    arch: Skylake-S rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 2150 high: 3500 min/max: 800/4300 cores: 1: 3500 2: 3500
    3: 800 4: 800 bogomips: 28009
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] driver: nvidia v: 525.60.11
    arch: Pascal bus-ID: 01:00.0
  Device-2: WaveRider USB 2.0 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-10:6
  Display: x11 server: X.Org v: 21.1.4 driver: N/A resolution:
    1: 1920x1080~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce GTX 1060
    3GB/PCIe/SSE2 direct render: Yes
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full
    mac: 70:4d:7b:65:8b:2b
  IF-ID-1: docker0 state: down mac: 02:42:46:a4:e0:58
  Local Storage: total: 4.08 TiB used: 3.25 TiB (79.8%)
  Processes: 227 Uptime: 2h 43m Memory: 15.57 GiB used: 5.16 GiB (33.1%)
  Init: systemd Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2328 Shell: Zsh
  v: 5.9 inxi: 3.3.23

Also it is useful to disable it, sometimes you can get 5-10 frames performance in games. Also it’s should be a functioning feature. Thank you for the replies.

To confirm, you’ve since rebooted?

Does this also occur with kernel 5.15 LTS?

(When did you notice this started happening?)

Yes, I’ve since rebooted,
I haven’t tried with a different kernel.

I wouldn’t remember exactly when this started happening, perhaps only about 1 week ago.

Can you install the 5.15 LTS kernel via the Manjaro tool, then reboot into the 5.15 kernel and test this out?

I’ve booted into 5.15.81-1-MANJARO x86_64, seems to be the exact same behaviour unfortunately.

What about with a new test user account, to see if this behavior persists with a fresh user profile?

Good shout, behaviour does not persist on a new user account. No black screens.


So one non-destructive test is to rebuild the Plasma cache.

  1. Log out
  2. Switch to TTY2 with CTRL + ALT + F2
  3. Login to this TTY session with your main user account
  4. Stop the display manager
sudo systemctl stop display-manager.service
  1. Rebuild the Plasma cache
kbuildsycoca5  --noincremental
  1. Wait about 10 seconds
  2. Then restart the display manager
sudo systemctl restart display-manager.service && exit
  1. Login to KDE

If this doesn’t make a difference, you might have to delete/rename your current ~/.local/share/kscreen/ folder and/or try to find an errant config or cache. If you delete/rename this folder, it will reset your display and monitor settings.

Don’t just nonchalantly delete your entire ~/.cache folder, unless you are certain you’re not using anything within. (For example, this is where your thumbnails are cached. Some programs greatly speed things up by saving data in the cache. I use one myself, and to delete my cache folder would be devastating.)

Bad news, first option (to rebuild the Plasma cache) appeared to nothing at all.

Then the second option, interestingly enough, didn’t fix the issue. However it changed the black screen (when the compositor is disabled) to be all black. As before there was a slight slither of the desktop visible at the bottom of the screen, now there’s none.

Also, to add, when the compositor is disabled, the cursor is still there; you can move applications and still interact; when you fullscreen a window, the box to show it’s going to fullscreen is there and finally the KWin debug console still renders fine.

You’re referring to the kscreen folder?

So then there’s likely an errant config file and/or cache.

You could try to log out, switch to TTY2, rename ~/.cache to ~/.cache.bak, then log back in to see if it resolves. If it does, and you don’t mind a new cache, then you can just delete the old ~/.cache.bak folder.

Otherwise, you’ll have to figure out which config file is causing the issue. It could even be interrelated to your Nvidia settings.

No luck with renaming ~/.cache, So I assume it must be something else that, like you said, is interrelated with Nvidia settings. I’ll keep trying with different configs and report here if anything changes.
Other than that any other pointers are greatly appreciated.

Many Thanks.

A likely candidate is the kwinrc config file. It’ll reset your effects and compositor settings.

Logout of KDE, and then from TTY2:

mv -v ~/.config/kwinrc ~/.config/kwinrc.bak

Then log back into KDE.

This didn’t change anything unfortunately.

I figured it out, I really should’ve noticed this earlier. I installed an application known as Gromit-MPX that let’s you annotate on screen. When running it causes this issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.