Disabling auto-mute during startup

Hello
Im struggling with disabling auto-mute during kde startup
kde has a lovely startup sound and i want to hear it on every boot :smiley:

I know that arch wiki has 3 different ways achieving that but in my case nothing works so far , during every boot pulseaudio is muted

on alsamixer the auto-mute is absent its not there so i get an error that i cant find auto-mute option to disable

amixer --card=0 sset ‘Auto-Mute Mode’ Disabled
amixer: Unable to find simple control ‘Auto-Mute Mode’,0

anyhelp?

It’s not an auto-mute. Startup sound is effectively broken in the latest Plasma releases. Manjaro is not the only distribution affected by this, and the problem is known to the upstream KDE developers. :man_shrugging:

2 Likes

startup sound will be something beautiful to have,
but its not about that , kde starts muted i have to manually unmute it every time, and archwiki doesnt helped me so far

Try to unmute it using alsamixer and then store the settings with sudo alsactl store

1 Like

I have this same problem. Using the tricks on this page do not help. Using alsasctl store does not help.

This started happening several months back after a Manjaro patch. Was working fine for years prior. Every time I boot up, I have to unmute.

I tried deleting the pulse directory under my user account and that didn’t help either. It recreates it, but things are still muted.

I had the same issue on one of my computers, and someone suggested this, and it worked! See it that helps.

Disabling auto mute:
systemctl --user mask pipewire.socket --now
systemctl --user disable pipewire.service --now

Thanks, but this did not work. Also tried disabling locally as well as masking the pipewire.socket globally. I am guessing pipewire is not the cause.

Do you have "PulseAudio Volume Control (Pavucontrol) 1:4.0-2 " installed? I installed this as well when I was having the same issue.

Tried installing that too now, but no go. Muted on startup. It is not a showstopper, just annoying, especially when it was originally working when it was working at one time.

I just noticed that it defaults to muted every time I change the output controller from stereo to quadrophonic… So seems to mute itself every time the audio restarts.