Disable Wayland in Manjaro GNOME

Hi there. I have to install Anydesk/Teamviewer on my Manjaro GNOME (Linux 5.8.18-1-MANJARO x86_64 20.2 Nibia), which don’t support Wayland at all.

I can’t switch to Xorg in my login window (I’ve tried to choose GNOME on Xorg in my login screen, but I can log in, it just displays the login screen again after entering the password).

I’ve tried to uncomment WaylandEnable=false in /etc/gdm/custom.conf, but after rebooting I wasn’t able to login - I just saw a blinking dash screen. I had to discard these changes in order to be able to log in. Does anyone know how to disable wayland in other ways?

UPD. I dunno if it matters, but I use video-vesa GPU driver for AMD Radeon Graphics, laptop: Honor MagicBook Pro (HLYL-WFQ9)

1 Like

That’s the way to do it.

Go to tty 3 and back. If that doesn’t help, restart gdm from tty3.

@spikerguy @Ste74 do you remember how you got gdm to work with xorg?

1 Like

Thanks for the reply. Could you please specify what did you mean? I haven’t worked with tty3 before and I’m not sure that I got you correctly

You have multiple virtual consoles. Tty1 is running gdm, and gnome runs in tty2. The rest are usually normal terminals.

To access tty3, press ctrl+alt+f3. Ctrl+alt+f2 gets you tty2 and so on. Restarting gdm will also automatically bring you back to it’s tty.

1 Like

Yes, thanks for the explanation. I tried to repeat the steps you said but it didn’t help me, I still can’t login with Xorg. If you want I can attach a video of the problem

Graphics driver not needed is the reason, I did this some time before…
Resolution: —> manjaro-settings-manager --> Auto install Open-Source Driver (in Wayland session!)

sudo mhwd -r pci $(mhwd -li |grep ‘video-’ | awk ‘{print $1}’)
sudo mhwd -a pci free 0300

1 Like

Try starting a X.Org session from TTY using


I do this but with lastest gdm in my HW now I don’t have any problem…

1 Like

Thanks, guys for the help. I’ve solved this problem by reinstalling Manjaro again