Disable unlock default keyring in Gnome

I’m using Manjaro Gnome and I don’t want to use password on login. So I turned on automatic login feature. When I log in, it shows me a window: Authorisation required (unlock default keyring). Is there any way how to get rid of this window and automatically unlock this keyring? (I take risks if someone manages to use my laptop)

You should have a look at GNOME/Keyring - ArchWiki
Will help to exactly identify the reason why you are prompted to unlock it and how to deal with each scenario you need it for.

Thank you, but I installed Manjaro yesterday (was using windows before) and I’m practically newbie. If someone could explain it step-by-step I would be thankful.

The Arch Wiki does have a lot of technical info which can be offputting, but reading the tips & info between that, you can see the green box with tips that apply to your question:

Tip:

  • To use automatic unlocking with automatic login, you can set a blank password for the default keyring. Note that the contents of the keyring are stored unencrypted in this case.

You will find the Passwords & Keys app in your Accessories & you can there set the password for the Default Keyring. You can set it blank by just pressing enter instead of typing anything.

It’s unsecure having a blank keyring password, but you’ll have to decide your balance of convenience & safety.
It’s probably a good idea for a laptop to not have auto-login, you only have to login once when you turn it on, so it’s not a big hassle, but it is much better in case the worst does happen.

3 Likes

One option is to just remove gnome-keyring, but that might cause some issues down the line. But if you have the keyring, it needs to be unlocked somehow. If you use autologin with system encryption, then it is possible to use the decryption password instead of login screen password. But other than that, I what you actually want is to not use gnome-keyring at all. If you don’t use ssh or git, then you can do without if you accept the risks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.