Disable touchscreen at boot on Lenovo Yoga S1

I have a 2-in-1 with a Wacom digitizer and a normal touchscreen. I will mostly be using it for drawing so I want to disable the touchscreen at boot, and have a toggle for it on my panel. I currently have this code in an autorun config file I made:
#disable finger touch
xinput set-prop "ELAN Touchscreen" "Device Enabled" 0
(taken from this thread: https://forum.manjaro.org/t/disable-touch-screen-on-a-netbook-laptop/53372)
This works, the screen is disabled on startup and when I type it manually, however it then enables itself shortly after. If I run it a few times, re-running each time it gets re-enabled, then it stays disabled. There is also a graphical way to enable/disable it through settings and this stays disabled if I click it.
If anyone can tell me what is going on and how to disable it so that it is not re-enabled that would be great :slight_smile:

Thank you in advance.

I have found a way to change the xfce settings directly using this method: https://forum.xfce.org/viewtopic.php?id=10836, which does not seem to be reset.
I still don’t know why the xinput setting is getting reset, but it doesn’t matter.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.