Disable Touchpad while typing not working

The setting to disable touchpad while typing on my Pinebook Pro does not appear to actually work. Anyone else experience this issue? Currently on newest 20.08 but I do not recall it ever working prior to this update either.

I’m not sure if it fixes your problem, but the touchpad firmware may need to be updated if you have one of the older batch of Pinebook Pro.

https://wiki.pine64.org/index.php/Pinebook_Pro#Trackpad

see the above link for the links to the firmware updaters on pine64’s wiki

I run Manjaro-Sway on pinebook pro en tried the firmware update. The firmware updates, but the problem persists. The other options work, but disabling while typing does not. Quite frustrating. Any ideas?

input "type:touchpad" {
    tap enabled
    natural_scroll disabled
    accel_profile adaptive
    dwt enabled
    pointer_accel 0.6 # set mouse sensitivity (between -1 and 1)
}