Disable touchpad while typing not working for me

I canj’t really use it when my hands hit the touch pad and make the mouse go somewhere else while i’m typing.

the checkbox [x] disable while typing seems to not do anything.

its a brand new tuxedo laptop running kde

There is an extension/applet called Touchpad Indicator, by atareao. It helps me turning off the touchpad most of the time, except when there is no mouse attached to the computer.

It might help you. There are some other config option to explore.

Doesn’t seem to make any difference.

According to this How do I deactivate my touchpad? - TUXEDO Computers. you might have to check if you have the parameter acpi_osi= ! set in /etc/default/grub

Continuing to their next article, will also point to this libinput - ArchWiki

so i just put: “acpi_osi= !” in my grub file? I don’t see know if this is correct. if it isn’t it won’t boot. Can you give me the exact line to add?

Well, you open the file /etc/default/grub with your favorite editor, and in the line where you might have:

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"

you make it to be

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=! udev.log_priority=3"

Save the file then you run from terminal:
sudo update-grub

See more about Kernel parameters - ArchWiki

Might be that KDE is not suitable for this extension/applet. Sorry.