Disable Touchpad when USB Mouse is connected

Hey there, I’m pretty new to Manjaro and still configuring the System.
I have installed the KDE Edition of Manjaro.

Now I wanted to disable the touchpad of my laptop, when I plug in a mouse via USB.
Is there any working tutorial how to do this? I have already tried it with the help of this site.
I also tried searching for other methods, but most of them are old forum posts and so they are not available anymore or not working anymore

Hope somebody can help me

Hello and welcome,

In principle is fantastic that you went to wiki, but on KDE Plasma is easy to just enable that option
In Input Devices > Touchpad on the last tab.

image

Let us know if that is working or not for you.

Thanks for the quick reply.
I have searched the settings in the first place, but it don’t have these tabs in the settings :frowning:

Thats how it looks for me, but there is no option to disable the touchpad when a mouse is connected.
Maybe I should also say that i have chosen the minimal installation

Is an important aspect, but the most important is that you use the xf86-input-synaptics driver apparently, hence the lack of those options in your case.
Please share from terminal:
cat /etc/X11/xorg.conf.d/30-touchpad.conf
Make it be as formatted text. Use </> icon above

Or maybe is a different file … 50-touchpad.conf ?

Now I get those options in the settings. I have tried a few things I found online and now the options appeared after a reset.
if I remember it right, it was installing libinput and some other Synaptics driver and also editing a config file…
But I can’t say what helped me in the end (as solution for others that may search for help)

The option in plasma is only accessible with the synaptic driver… not with libinput.
I don’t say it’s not possible to do it with only libinput (i don’t know) but the GUI option is only visible with the synaptic driver.