Disable touchpad how?

Although I am using my USB mouse much less using i3, my touchpad on the laptop is too sensitive and acts up when my fingers are typing on the keyboard. I like to disable it completely and use USB mouse. Is there a simple command that will do this with libinput?, I would prefer not to install synaptic if possible. Editing 30-touchpad.conf to MatchIsTouchpad “off” does not seem to work.

Section “InputClass”
Identifier “touchpad”
Driver “libinput”
MatchIsTouchpad “on”
Option “Tapping” “on”


check if you can disable in UEFI/BIOS

Hi @gychang,

Although I don’t use, or even have a laptop and thus no touchpad, I have found this post online that seem to describe the steps pretty well:


If you do not want or cannot use synclient, you could also use xinput. The procedure is somewhat similar.

list all xinput devices: xinput

Part of the ouput could look like this:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=13   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=17   [slave  pointer  (2)]

It this particular case my touchpad has id=17 and its full name is “ETPS/2 Elantech Touchpad”.

The command to set a property is xinput set-prop. The property to enable or disable the touchpad is Device Enabled, so to enable or disable it type:

Turn touchpad ON: xinput set-prop <id> "Device Enabled" 1 (where <id> is your device id, in my case 17)

Turn touchpad OFF: xinput set-prop <id> "Device Enabled" 0

Turn palm detection ON: xinput set-prop <id> "Palm Detection" 1

Turn palm detection OFF: xinput set-prop <id> "Palm Detection" 0

To query available properties: xinput list-props <id> OR xinput list-props <full-name>, this should be quite similair to synclient -l.

Links for further reading

ubuntu - wiki - input


When setting properties through either xinput or synclient the properties are not set to the other tool. They are also not set in unity-control-center.

Hope this helps!

Thanks!, works perfect.

good idea!, unfortunately on my laptop no touchpad control…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.