Disable one of the audio profiles of the graphic card

There are two HDMIs on my AMD 570 graphic card.

Each HDMI is connected to a monitor.

Monitor on HDMI 3 has bad sound so I want to disable that HDMI’s audio profile, so KDE won’t switch to that audio profile.

I know how to disable an audio device in KDE, but there is no obvious way to turn off one profile of the many profiles of a device.
Any idea? Thank.

If the audio output for HDMI 3 is muted in ALSA the sound server (PulseAudio or PipeWire) will detect that this output is not available and will avoid connecting to it

Find the ALSA card number for the HDMI device with this command

cat /proc/asound/cards

(HDMI output device is usually card 0, but not always)

ALSA audio controls for the card can be adjusted in alsamixer

alsamixer --card=0

use and to select the output
(digital outputs might be shown as S/PDIF or IEC958 rather than HDMI)

and M to mute the output

And run this command to save ALSA settings so the output remains muted when system is booted

sudo alsactl store
1 Like

Thanks a lot. The instruction is clear and makes sense. This should be working but somehow it doesn’t work for me. I have the following results.

  1. The HDMI 3 is muted when the system boots, but the HDMI 3 is chosen as the audio output. We thought if it is muted, the system will pick HDMI 4 as the default audio output.
  2. The HMDI 3 will override the configuration on boot as if I have not saved the configuration but I save before boot by doing
sudo alsactl store

The system will always pick HDMI 3 no matter if it is muted or not by configuring in

alsamixer --card=0

Hence I will just switch the good speaker monitor to HDMI 3 so the system will take it as default.