Disable GTK theming for certain applications and allow their stock themes

Hello,
I have this Problem in eclipse, that i cannot read Variables due to theming and it is really distracting me.
How do I disable GTK theming for certain applications and allow their stock themes?
I would like to specifically exclude stm32cubeide.

I woulde like something like this, but with “none” or something like that.
rel: https://askubuntu.com/questions/1149986/eclipse-looks-terrible-with-linux-dark-theme.

Cheers

https://wiki.archlinux.org/title/Eclipse#Disable_GTK_3

1 Like

It doesn’t change anything.
Where do I put it?
I put:
export SWT_GTK3=0 eclipse
in:
~/.profile
~/.xinitrc
/etc/environment
and rebootet everytime.
I also put it in terminal and it did not work.

it can be disabled by prepending SWT_GTK3=0 environment variable when starting Eclipse

SWT_GTK3=0 eclipse

Emphasis mine: this is what the command launching Eclipse should look like, rather than setting the environment variable to everything.

Also:

Another option to achieve the same effect is to add the following to Eclipse’s ini file, before --launcher.appendVmargs:

/usr/lib/eclipse/eclipse.ini

--launcher.GTK_version
2

It doesn’t change anything though…
even if run said command in terminal:
SWT_GTK3=0 eclipse
I still cannot read anything.

And I also would like to have that solution permanently and for other applications as well.

As I also have it in gedit:
image

If it is that big an issue - and others have the similar experience with dark themes - the right place would be to file a report with eclipse developers - or use Adwaita - which is considered the defacto Gnome theme - it even exist in a dark version too.

1 Like

The thing is the GTK theme applies to all GTK applications by default. Some may allow to use different theming, but that’s independently from the others.
So the easiest way may rather be to use another GTK theme.


Doesn’t Gedit have a color scheme setting?

1 Like

Great.
Now my eyes hurt, but at least I can read.
:+1:

Sorry about that - I don’t like it either - but in such case it is the lesser evil :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.