Different operating system detected from Browser

All services that I am logging into via my web browsers such as Firefox, etc. are detecting Windows 10 system, even though I’m using up to date Manjaro OS. Previously all services used to detect Linux system clearly. But recently this suspicious behavior started to show up ever since I updated all my applications via sudo pacman -Syu command.

Is this some kinda bug or malware? Are my data being tunneled through some other systems by any chance?

See the attachments below:

This might be a case of “welcome to the wonderful world of online tracking”.
Or it might be a bug in firefox where it’s cached that you logged in from windows (have you ever used firefox on windows 10?) with the same firefox id, but on your linux version something is disabled in reporting towards firefox.
Or its a combination where firefox links your harware id to your old windows10 login from firefox.
(I’m not really serious)
Tinfoil hat on. xD

No matter, would be very interesting to find out why.

Extensions? Does it happen in safe-mode?

firefox --safe-mode

@bedna Yes, I do have firefox installed in Windows OS (i have dual boot setup in my hardware fyi). Could you suggest a way to fix this issue?

Yes, even in safe mode, the issue persists!

Sorry, I can not.

Just standard stuff like:
Browser Privacy, are they set the same on both linux and your win? (go strict imho)
Try cleaning out Cookies and Site Data & History.
Under Firefox Data Collection and Use, do you have the same settings on your windows as your linux?

What is your browser telling websites? You can check for example with this site: xhaus.com: HTTP header check. Watch the User-Agent. Probably it is saying Windows. You have to find out why. I would say that some extension has changed it for some reason.

You can also check and reset the user agent: How to reset the default user agent on Firefox | Firefox Help

@cfinnberg After reading the document you linked, I realized my browser had an issue with privacy.resistFingerprinting preference. After resetting the flag, the problem is gone for good. Thanks a lot.

You were not actually having a problem. The latest versions of Firefox now default to having anti-fingerprinting enabled by default, and one of the ways to avoid fingerprinting is to turn your User-Agent string into the most generic one there can be, which is of a Mozilla-based browser running on top of Microsoft Windows.

So, by disabling this, you are now allowing websites to track you and target you with advertising, based upon the fact that you’re using GNU/Linux and that your browser is telling them that. :man_shrugging:

1 Like

As far as I can see, it’s still an experimental feature that can cause some problems and it’s not activated by default:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.