Dial tcp: i/o timeout

  Kernel: 5.15.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: GNOME 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: EUCN19WW date: 05/12/2020
  ID-1: BAT0 charge: 27.3 Wh (57.1%) condition: 47.8/60.0 Wh (79.7%) volts: 15.1 min: 15.4
    model: Celxpert L19C4PC0 status: Discharging
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
    rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1396 high: 1398 min/max: 1400/2900 boost: enabled cores: 1: 1397 2: 1396
    3: 1398 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397 12: 1397 13: 1392
    14: 1397 15: 1397 16: 1396 bogomips: 92659
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo driver: nvidia v: 470.103.01
    bus-ID: 01:00.0
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 05:00.0
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:2
  Display: x11 server: X.org driver: loaded: amdgpu,nvidia
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A
    bus-ID: 05:00.5
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 05:00.6
  Sound Server-1: ALSA v: k5.15.21-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 2000 bus-ID: 03:00.0
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 150.75 GiB (31.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB temp: 41.9 C
  ID-1: / size: 459.79 GiB used: 150.75 GiB (32.8%) fs: ext4 dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p2
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): N/A
  Processes: 383 Uptime: 48m Memory: 15.07 GiB used: 4.11 GiB (27.3%) Init: systemd Compilers:
  gcc: 11.1.0 clang: 13.0.1 Packages: 1547 Client: gnome-shell v: 41.3 inxi: 3.3.12

I’m trying to play Crusader KIngs 3 online and I’m unable to login to my Paradox account through the game. So, I reached out to Paradox and they suggested updating the launcher first, but for some reason I can’t update it because I’m getting an error:

33m2022-02-13 18:58:52 [repository] [WARNING][0m Error in response: Get : contacting repo: Get https://api.paradox-interactive.com/patch/repo/launcher-v2_1-linux-64/_keys/public.gpg: dial tcp: i/o timeout

They said that it could be a firewall, but this specific laptop I’m using doesn’t have a firewall and the connection it uses also has firewall turned off. I’ve tried turning the router firewall on and setting an exception. I’ve also tried using other connections and I still get the same error. They believe that it’s something on my system, but I don’t have anything that can possibly prevent it from connecting to their API.

Does anybody have any idea what could be happening?

Do you have set a custom DNS?

I’m using the Cloudflare DNS. I’ve also tried the Google DNS and I also tried the my ISP’s default.