dGPU GPU Always active with 5.x kernels

My dGPU is (maybe) always active after I updated my kernel from 4.19 to any 5.x kernel

I use Freon Extension in GNOME and I have activated my GPU temps and when I switch to 4.19 my gpu temps go and my laptop temps are in normal 45 degrees but with any 5.x kernel the temps are always persistent and the laptop temps are in high 60 to 80 when idle sometimes. This is affecting the battery life also. I am getting like 4 hours before with 4.19 but with any 5.x i get 1.5 hours.

Thank you for your help and time in advance.

System Info:

  Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 81HN v: Lenovo V130-15IKB 
  serial: <filter> Chassis: type: 10 v: Lenovo V130-15IKB serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO 
  v: 8VCN17WW date: 05/02/2019 
  ID-1: BAT0 charge: 26.1 Wh (100.0%) condition: 26.1/30.6 Wh (85.2%) 
  volts: 8.5 min: 7.6 model: CPT-COS L17C2PB3 type: Li-poly serial: <filter> 
  status: Unknown 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  RAM: total: 7.12 GiB used: 3.23 GiB (45.3%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check rev: A cache: L2: 6 MiB bogomips: 28800 
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 1-5:3 chip-ID: 04ca:7070 class-ID: 0e02 
  Display: wayland server: X.Org compositor: gnome-shell driver: 
  loaded: amdgpu,ati,intel unloaded: modesetting alternate: fbdev,vesa 
  resolution: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: yes 
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: efa0 bus-ID: 02:00.0 chip-ID: 8086:3166 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: c000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-8:4 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 1.13 TiB used: 153.66 GiB (13.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: LCM2 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WDS240G2G0B-00EPW0 
  size: 223.58 GiB speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 0000 
  scheme: GPT 
  Optical-1: /dev/sr0 vendor: PLDS model: DVD-RW DA8AESH rev: XL6M 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r state: running 
  ID-1: / size: 210.11 GiB used: 153.66 GiB (73.1%) fs: ext4 dev: /dev/sdb2 
  label: N/A uuid: e9cebb32-0da4-461b-a313-2d6077e5f85c 
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat 
  dev: /dev/sdb1 label: N/A uuid: 6AFD-AE9D 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 label: N/A uuid: 5e28faa4-bdc2-492c-8cfc-906809733835 
  ID-1: /dev/sda1 size: 232.83 GiB fs: ext4 label: HDD.Part1 Bkps 
  uuid: 6ba795dc-2154-4b2e-bb88-3e55ebd23235 
  ID-2: /dev/sda2 size: 7.45 GiB fs: swap label: swap 
  uuid: d7488ea0-db70-4f68-9f0e-e35530a0c752 
  ID-3: /dev/sda3 size: 465.85 GiB fs: ntfs label: HDD.Part3 Personal 
  uuid: 1A306D1F34155F53 
  ID-4: /dev/sda4 size: 225.38 GiB fs: ext4 label: HDD.Part4 PCBkp 
  uuid: 12032873-a888-4fbb-b4da-f5c523b559b4 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse 
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c534 class-ID: 0301 
  Device-2: 1-5:3 info: Lite-On Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 04ca:7070 class-ID: 0e02 
  Device-3: 1-8:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 
  speed: 5 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 64.0 C mobo: 60.0 C gpu: amdgpu temp: 64.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 279 Uptime: 1h 25m wakeups: 23 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: 1496 pacman: 1489 snap: 7 Shell: Zsh v: 5.8 
  running-in: gnome-terminal inxi: 3.3.04

EDIT: grammar and typos

Are you sure you have a second, dedicated GPU? Your inxi Output and your Model Lenovo V130-15IKB indicate you have just one integrated Intel GPU.


Maybe worth updating the BIOS
You had a similar issue on the archived forum, and i pointed to this:
but is about the 4.x kernels, and on that one it seems it works for you. Have you tried all 5.x series (except the EOL ones) and see if any difference?

I know. But It seems i cant update the bios from linux. I’d have to install Windows and then install then re-install Linux

Yes, that was exactly opposite… There I thought the dGPU was not working but you pointed out that, it was.

I have. They all behave similarly. the LTS 4.19 works the best for me.

Then that kernel is a keeper.

Have you tried to work with http://aur.archlinux.org/packages/switcheroo-control ?
To install:
pamac build switcheroo-control

I dont know why but the list of providers is zero now… Even in xrandr and in switcheroo