Device not found skipping fsck. However I can`t chroot ( disk was not AHCI )


Today I decided to reapply thermal paste on my dell gaming notebook (here we go…). After doing so successfully I tried booting my linux installation which is in my main SSD and I get an error

ERROR: device 'UUID=some-uuid-in-here' not found. Skipping fsck.
mount: /new_root: can't find UUID=some-uuid-in-here.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off

Most solutions are related to chrooting to the drive from a live usb. However, I can`t seem to find my SSD drive anywhere from this live boot. Even though the BIOS finds it and tries to boot, it also gets warm so it is definitely connected.

[manjaro-gnome manjaro]# manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
==> ERROR: No Linux partitions detected!

The only weird thing that happened when reassembling the laptop was that it took a while for it to boot up again, it seems to be related to the motherboard battery or something. Any other ideas I can try?

If it’s worth anything, everything worked fine before disassembling.

Its possible manjaro-chroot automation is not smart enough for whatever happened with your partition configuration.
Take a look at things (gparted, lsblk, etc) and verify the path you need to use, and attempt chroot by hand…

Thanks for the answer!

I ran lsblk and I get:

loop0    7:0    0 146.3M  1 loop /run/miso/sfs/livefs
loop1    7:1    0 976.6M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1.7G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 921.4M  1 loop /run/miso/sfs/rootfs
sda      8:0    0 931.5G  0 disk 
sdb      8:16   1   7.5G  0 disk /run/miso/bootmnt
├─sdb1   8:17   1   3.7G  0 part 
└─sdb2   8:18   1     4M  0 part

Where sda is my HDD and sdb is my current USB stick. The other ones I’m not sure what they are, however none of them seem to be my SSD. Gparted shows the same devices. Just to give more info, I ran fdisk -l:

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: TOSHIBA MQ02ABD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 7DE73988-776C-4CA6-98CE-FFF6995AE9A1

Disk /dev/sdb: 7.45 GiB, 8002732032 bytes, 15630336 sectors
Disk model: Cruzer Blade    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Which TOSHIBA MQ02ABD1 is indeed my HDD.

Is it possible that the SSD is faulty even if BIOS is still able to find it and try to boot from it? What else can I try to do to find it?

Edit: I’m not sure if its worth anything, however I can’t find anything like nvme (I guess this is how it would show up?) in /etc/.

In the output above it shows manjaro-chroot trying to use sdb (your live usb) … so it never attempted on sda (your hdd) ,

So manual will be the next step, but what to do depends on filesystem … which isnt shown.

Please refer to the wiki.

To list partitions with uuid and filesystem you can use


And manual chroot instructions are

Manual chroot

(Unnecessary if you have used manjaro-chroot) Mount the partitions using the designated temporary mountpoint and always start with root

root # mount /dev/sdyC /mnt


### With a BTRFS filesystem, you should note that the subvolumes must be mounted. That would be in such a case: root # mount -o subvol=@ /dev/sdyC /mnt ###

Then - if applicable - mount boot

root # mount /dev/sdyB /mnt/boot

Then - if applicable - mount efi

root # mount /dev/sdyA /mnt/boot/efi

Create the chroot environment and use bash as shell

root # manjaro-chroot /mnt /bin/bash

From there you should be able to get in and check/edit /etc/fstab

Ok, that error makes more sense now. However, I’m not sure if manjaro-chroot would search sda since there is no linux partition on my HDD, it is empty at the moment.

I believe I can follow these instructions once I can find a way to reach my SSD, which contains my linux partition. I just don’t understand how my PC tries to boot from it but I can’t find it in manjaro.

Edit: in the emergency shell, running blkid it only shows only SDA and SDB. No nvme as well… How is this possible?

Sorry, I must have skipped the missing SSD part, I thought your system was on sda. :sweat_smile:

But … then … so far nothing is showing the SSD.
Does it appear from anything else other than EFI, such as from another live system? Or? …

If I were you I would probably try to reseat the drive if nothing could pick it up.

Don’t worry! I’m glad to just have someone to even talk to at this moment :disappointed_relieved:

It shows up as a UEFI boot option and now I’ve tried to boot from a windows installer and it identifies two storage units, one with 931.5GB which is my HDD and another with 936.5GB which I believe would be my SSD (I’m not sure how to get more information about the unit in this case).

This means the unit is working, right? Maybe it’s some kind of firmware issue on my SSD? I’m really confused.

Edit: Manjaro installer does not find it as well…

Managed to have it boot!!! Hooray! I’ve found another post about windows finding an SSD and Linux not finding it. Turns out my MB for some unknown reason changed the SSD to run in RAID mode, when it should be in AHCI. This did the trick.

Thank you so much for helping me in troubleshooting this issue, cscs!!

Ah. Maybe the default and it reverted?

In any case I’m glad it worked out. :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.