Device has wrong permissions after reboot

I have a NVMe SSD, formatted as NTFS, with mount-point /media/files. When I set it up I had write access to it as expected. After a reboot, only root had the write permission. I cannot use chown on a mounted device, so I checked the /etc/fstab directly. It was set on ‘users’. I changed it to ‘auto,nofail,defaults’.
I have the exact same issue with an USB SSD formatted as ext4, which I would like to use for TimeShift.

What do I have to do to have write permission as a user on both devices?

Thank you very much in advance for your advice!

NTFS file permissions are only virtual in Linux,
no change there will help - especially knowing that they worked just fine until … they didn’t :wink:

The filesystem may need to be checked before it can be mounted rw again.

This is best done from a Windows system.
I think it works from Linux as well, but not in all cases.
But I can’t tell you the command.

You’ll probably find it if you need, if you don’t have Windows to do it for you, now that you know what to look for.

If you use this drive from Windows as well, make sure you disable fastboot as it leaves the filesystem in an unclean state only Windows knows about.

Very weird: It is working now. Maybe changing fstab needs two reboots to work properly or idk. xD

Now it’s only the (ext4) USB SSD that has the wrong permissions, but this one is not present in the fstab file. Any ideas on that by any chance?

there are posts about that here
… and in the wiki, very likely …
You need to change permissions on the mount point of the device - the permissions of the device itself aren’t important
those of the mount point are

I would look it up for you, but don’t have time and patience now :wink:
you’ll find it …

Ok, now I have write permission on the external SSD, but a warning:

An error occurred while accessing 'Home', the system responded: The requested operation has failed: Error mounting system-managed device /dev/sdb1: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error

The /etc/fstab line is
/dev/sdb1 /mnt ext4 auto,nofail,default 0 0

something appears to be seriously wrong here
that device get’s mounted to /mnt
You set that up.
the error says that HOME is on that device
which is very likely wrong, confusing for sure
the mount options in fstab look “strange”, too

show your whole /etc/fstab please
and some general system information via inxi
see the posts mentioning “how to provide good information”


UUID=f6a95c86-209e-4628-a64d-5b0d24be0c95   /                 ext4   noatime                     0 1
UUID=4CF5-9CF2                              /boot/efi         vfat   umask=0077                  0 2
/dev/nvme1n1p1                              /media/files      ntfs   auto,nofail                 0 0
UUID=8191b21c-f32a-45cb-9250-8efb14701e35   /media/external   ext4   auto,nofail,default,users   0 0


sda           8:0    1 111.8G  0 disk 
├─sda1        8:1    1   100M  0 part /boot/efi
├─sda2        8:2    1    16M  0 part 
├─sda3        8:3    1 107.9G  0 part 
└─sda4        8:4    1   507M  0 part 
sdb           8:16   0 931.5G  0 disk 
└─sdb1        8:17   0 931.5G  0 part 
nvme0n1     259:0    0 931.5G  0 disk 
└─nvme0n1p1 259:2    0 931.5G  0 part /
nvme1n1     259:1    0 931.5G  0 disk 
└─nvme1n1p1 259:3    0 931.5G  0 part /media/files

/dev/sdb1 is just called HOME because you labeled it so - probably
it isn’t your HOME partition

try running a filesystem check on it:
sudo e2fsck -v /dev/sdb1

1 Like

Thank you very much for your support. I never labeled it HOME myself, though I created the partition table and formatted it with gparted. But as far as I remember gparted never labled anything HOME by itself. :confused:

e2fsck 1.46.0 (29-Jan-2020)
/dev/sdb1: clean, 2434861/61046784 files, 111919138/244181940 blocks

you said:

but then you posted your /etc/fstab

and this is not in it

this is incoherent information no one can work of

Yes, I’m sorry, I changed it in between to see if it does not like /mnt as a mount-point, because I think that was the general mount-point for external devices. Therefore, I changed it to a specific folder. I apologise for not clarifying this.

to whichever specific folder you changed it to …
comment out that line in /etc/fstab - for now

if it is an external device
it’ll show up in your file manager once you plug it in

it should also be possible to say:
mount /dev/sdb1 /mnt
and it should be attached to /mnt
and the contents should be available there

1 Like

I commented that line out and rebooted. After reboot, the device shows up, but still with only root having write permission. Unmounting, plugging it out and re-plugging it in brings no remedy. :confused:

… or create a folder on it and give it the appropriate permissions and then store your data in that folder - AFAIK

there are a few topics here on this forum that deal with how to set this up
I don’t know exactly, off the top of my head.

1 Like