Desktop unresponsive after enabling "Material Shell"

Hi! I installed Manjaro gnome recently and have taken a few days to familiarise with and customise this to me completely new OS. Everything was going well, but last night as I was exploring the settings, in the “Extensions” window, I clicked the “Material Shell” switch. This completely froze my system for a long time, and after a few hours I turned the computer off (using the button). When I turned it back on, the material shell was running. I have automatic login enabled and arrive directly at the desktop. I can move the mouse, but not click anything or get any shortcuts to work. It is unresponsive. I am now writing this from my install USB which has the manjaro iso on it. Is there any way for me to turn off Material Shell, e.g. from inside this live USB?

Thanks in advance!

Teodor

In installed system,

  1. Press ctrl+alt+F3. This gives you console to log in to

  2. Run command

    gnome-extensions disable material-shell@papyelgringo

  3. run command

    systemctl restart gdm

  4. Profit

1 Like

It’s a bit more difficult to do from your live usb, but if you really want to, you can reset most your desktop settings by deleting the file /home/<your_user_name>/.config/dconf/user. But if you don’t want to lose all your settings, chroot into your system, change user with su <your_username> ( not sure if you can even do this in chroot), and then run the gnome-extensions command to disable material shell. But really, it is much more cumbersome to do from the live iso.

Aaand we’re back to normal. THANK you so much! The ctrl-alt-f3 seems like a very handy shortcut.

Very happy to be a manjaro user!

It’s is called tty or console. You have seven of those by default, F1-F7. Usually login screen runs in TTY1 and graphical session runs in TTY7, but gnome TTY2 for graphical session. So you can return to your desktop by pressing ctrl+alt+F2.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.