Desktop turns black after signing in, cursor still visible

Hello,

I came back to my computer a few minutes ago, and it displayed on the screen that I had to go to tty and enter loginctl unlock-session 2, and I did so. A torrent wasn’t working for me, so I restarted my computer, and now whenever I log into my account, the desktop and taskbar turn black, although the cursor is visible. However, when I log into the root account, it works normally.

Here’s my inxi dump:

System:
  Kernel: 6.1.80-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=14240bb8-bf84-482f-b273-cb482cd440ec rw rootflags=subvol=@ quiet
    cryptdevice=UUID=c7894bef-22f0-439b-80a2-ace067589e9b:luks-c7894bef-22f0-439b-80a2-ace067589e9b
    root=/dev/mapper/luks-c7894bef-22f0-439b-80a2-ace067589e9b splash
    udev.log_priority=3 split_lock_detect=off
  Desktop: KDE Plasma v: 5 tk: Qt v: 5.15.12 info: frameworks v: 5.115.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
Machine:
  Type: Desktop System: Dell product: OptiPlex 3010 v: 01
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Dell model: 042P49 v: A01 serial: <superuser required>
    part-nu: OptiPlex 3010 uuid: <superuser required> UEFI: Dell v: A22
    date: 11/29/2018
CPU:
  Info: model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1600 min/max: 1600/3200 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 1600 2: 1600 3: 1600 4: 1600 bogomips: 25549
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: PC Partner / Sapphire driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DP-2 empty: DP-1, DVI-D-1,
    HDMI-A-1, HDMI-A-2 bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
    temp: 42.0 C
  Display: x11 server: X.org v: 1.21.1.11 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0
  Monitor-1: DP-2 model: Viewteck GFV24C built: 2019 res: 1920x1080 dpi: 92
    gamma: 1.2 size: 530x280mm (20.87x11.02") diag: 599mm (23.6") modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi inactive: gbm,wayland,x11
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 24.0.2-manjaro1.1
    note: incomplete (EGL sourced) renderer: AMD Radeon RX 470 Graphics
    (radeonsi polaris10 LLVM 16.0.6 DRM 3.49 6.1.80-1-MANJARO), llvmpipe (LLVM
    16.0.6 256 bits)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Dell 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-3: C-Media TONOR TC-777 Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-1.3:4 chip-ID: 0d8c:0134 class-ID: 0300
  API: ALSA v: k6.1.80-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active (process) with: wireplumber
    status: active tools: pw-cli,wpctl
  Server-3: PulseAudio v: 17.0 status: off with: pulseaudio-alsa type: plugin
    tools: pacat,pactl,pavucontrol
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Dell RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.3:3 chip-ID: 0bda:8771
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
RAID:
  Supported mdraid levels: raid0
  Device-1: md126 maj-min: 9:126 type: mdraid level: raid-0 status: active
    size: 931 GiB
  Info: report: N/A blocks: 976224256 chunk-size: 64k
  Components: Online:
  0: sdb maj-min: 8:16 size: 931.51 GiB
  Device-2: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive
    size: N/A
  Info: report: N/A blocks: 538328 chunk-size: N/A
  Components: Online: N/A Spare:
  0: sdb maj-min: 8:16 size: 931.51 GiB state: S
Drives:
  Local Storage: total: raw: 1.56 TiB usable: 670.19 GiB used: 97.4 GiB (14.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 240GB SSD
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0BB3 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HUA722010CLA330
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A3EA
  ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter>
    scheme: MBR
Partition:
  ID-1: / raw-size: 183.23 GiB size: 183.23 GiB (100.00%)
    used: 57.72 GiB (31.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c7894bef-22f0-439b-80a2-ace067589e9b
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 752 KiB (0.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 40.04 GiB size: 40.04 GiB (100.00%)
    used: 39.68 GiB (99.1%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-81477fea-6b10-4c5f-8805-2b84f2b02142
  ID-4: /var/log raw-size: 183.23 GiB size: 183.23 GiB (100.00%)
    used: 57.72 GiB (31.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c7894bef-22f0-439b-80a2-ace067589e9b
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swap/swapfile
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1721
Info:
  Memory: total: 16 GiB available: 15.59 GiB used: 2.34 GiB (15.0%)
  Processes: 259 Power: uptime: 11m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.22 GiB services: org_kde_powerdevil,upowerd
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: 1527 pm: pacman pkgs: 1520 libs: 452 tools: pamac,yay pm: flatpak
    pkgs: 7 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash (su) v: 5.2.26
    running-in: konsole inxi: 3.3.33

Any help would be greatly appreciated. Thanks in advance.

There is no circumstance where logging in to the GUI as root is recommended to compare results with a local account. The difference in permissions alone ensure that you won’t get a fair comparison.

Create a new user profile and verify that it does not have the same issue. At minimum, this will help determine if the issue is limited only to the original profile. If the new profile does not suffer from the same issue, then moving to a new profile completely becomes a valid option.

Aside:- Going forward it might be worthwhile having your torrent destination directories located on a separate partition rather than within an encrypted profile. This would require configuration changes in whatever torrent package you use; in the graphical qBittorrent, for example, those changes can be made in: Preferences → Download.

Cheers.

Extra note … this 512mb swap is so small as to be virtually useless.
With 16GB of RAM you might not easily run out of memory but keeping something larger than 512mb would probably make sense.

Now to your issue here;

Your HOME is full. Thats probably the problem.

1 Like

That worked. I should’ve noticed that :sweat_smile:. Thanks for your help.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.