Desktop settings messed up at shutdown

Done.
I said yes to uninstall conflicting packages. Problem still present. I also created another new testuser, still the same problem.

I might look at foreign packages

pacman -Qm

And pacnews

pacdiff -o

But I still think there is also something about your skel/home.

$ pacman -Qm
celt 0.11.3-4
ceph-libs 15.2.14-1
dbus-x11 1.12.20-1
galculator-gtk2 2.1.4-6
gcolor2 0.4-9
gnome-icon-theme 3.12.0-6
gnome-icon-theme-symbolic 3.12.0-6
ipw2100-fw 1.3-10
ipw2200-fw 3.1-8
js78 78.14.0-1
libguess 1.2-4
libsidplay 1.36.59-10
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
metis 5.1.0.p10-2
nvidia-340xx-utils 340.108-1
qpdfview 0.5.0-2
qt5-styleplugins 5.0.0.20170311-25
systemd-fsck-silent 239-1

pacdiff command does not exist…

# pacman -F pacdiff
core/pacman 6.0.2-14 [installed: 6.0.2-18]

It should have been in the pacman package

# pacman -Ql pacman |grep bin
pacman /usr/bin/
pacman /usr/bin/makepkg
pacman /usr/bin/makepkg-template
pacman /usr/bin/pacman
pacman /usr/bin/pacman-conf
pacman /usr/bin/pacman-db-upgrade
pacman /usr/bin/pacman-key
pacman /usr/bin/repo-add
pacman /usr/bin/repo-elephant
pacman /usr/bin/repo-remove
pacman /usr/bin/testpkg
pacman /usr/bin/vercmp

But not any more.
Doing the same with a vm that has not been powered for months, shows that pacdiff has been removed from pacman package some time between 6.0.2-14 and 6.0.2-18.

Found pacdiff has moved to package pacman-contrib

# pacdiff -o
/usr/share/icons/default/index.theme.pacnew
/etc/passwd.pacnew
/etc/shells.pacnew
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/lightdm/lightdm.conf.pacnew
/etc/lightdm/lightdm-gtk-greeter.conf.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/pacman.conf.pacnew

This output doesn’t tell me much

pacdiff is in the now separate package pacman-contrib

Could that be what has happened to other packages too? That some file has been moved from an installed package into a separate package that is not installed - and that happens to be a file that xfce expected to find?

Is there any command that will list missing packages compared with packages that would be installed on a fresh install?
And based on the above list - check if all files for those packages has the correct checksum?
Is there any command that would list all settings files (that is not part of the user profile) that differs from installation defaults?

What does it tell you? :wink:

pacman/Pacnew and Pacsave - ArchWiki

be especially very careful with:
/etc/passwd.pacnew
ignore it! - just delete

same for index.theme.pacnew

I think I got one small step forward here.
Logged in at a working desktop I run:

$ screenfetch |grep WM

it returns

WM: Xfwm4
WM Theme: Default

then I reboot, and login as the same user (no all icons on the desktop is gone), and do the same:

$ screenfetch |grep WM

it returns

WM: Not Found

So I run

rm .config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml

reboot, and login as the same user (now all desktop icons are back), and I run

$ screenfetch |grep WM

it returns

WM: Xfwm4
WM Theme: Default

SO, something that is generated in the file
.config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml
is causing the window manager not to load at the next login.

Trying the same with a newly created test-user.
Logout from user marli
Login as test5… Profile is created.

$ screenfetch |grep WM

it returns

WM: Not Found

Right click on desktop - nothing happens
open thunar - put some files in the desktop folder - nothing is shown on desktop
So I run

rm .config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml

reboot, and login as the same test user (now all desktop icons are shown), and I run

$ screenfetch |grep WM

it returns

WM: Xfwm4
WM Theme: Default

So, even with a blank profile, the problem is present, but by deleting the file .config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml before logout/reboot, the problem is solved (until next login)

Problem clearly is that the windows manager does not start if the file xfwm4.xml is present. Why does it fail?

the content of xfwm4.xml looks like this:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfwm4" version="1.0">
  <property name="general" type="empty">
    <property name="activate_action" type="string" value="bring"/>
    <property name="borderless_maximize" type="bool" value="true"/>
    <property name="box_move" type="bool" value="false"/>
    <property name="box_resize" type="bool" value="false"/>
    <property name="button_layout" type="string" value="O|SHMC"/>
    <property name="button_offset" type="int" value="0"/>
    <property name="button_spacing" type="int" value="0"/>
    <property name="click_to_focus" type="bool" value="true"/>
    <property name="cycle_apps_only" type="bool" value="false"/>
    <property name="cycle_draw_frame" type="bool" value="true"/>
    <property name="cycle_raise" type="bool" value="false"/>
    <property name="cycle_hidden" type="bool" value="true"/>
    <property name="cycle_minimum" type="bool" value="true"/>
    <property name="cycle_minimized" type="bool" value="false"/>
    <property name="cycle_preview" type="bool" value="true"/>
    <property name="cycle_tabwin_mode" type="int" value="0"/>
    <property name="cycle_workspaces" type="bool" value="false"/>
    <property name="double_click_action" type="string" value="maximize"/>
    <property name="double_click_distance" type="int" value="5"/>
    <property name="double_click_time" type="int" value="250"/>
    <property name="easy_click" type="string" value="Alt"/>
    <property name="focus_delay" type="int" value="250"/>
    <property name="focus_hint" type="bool" value="true"/>
    <property name="focus_new" type="bool" value="true"/>
    <property name="frame_opacity" type="int" value="100"/>
    <property name="frame_border_top" type="int" value="0"/>
    <property name="full_width_title" type="bool" value="true"/>
    <property name="horiz_scroll_opacity" type="bool" value="false"/>
    <property name="inactive_opacity" type="int" value="100"/>
    <property name="maximized_offset" type="int" value="0"/>
    <property name="mousewheel_rollup" type="bool" value="true"/>
    <property name="move_opacity" type="int" value="100"/>
    <property name="placement_mode" type="string" value="center"/>
    <property name="placement_ratio" type="int" value="20"/>
    <property name="popup_opacity" type="int" value="100"/>
    <property name="prevent_focus_stealing" type="bool" value="false"/>
    <property name="raise_delay" type="int" value="250"/>
    <property name="raise_on_click" type="bool" value="true"/>
    <property name="raise_on_focus" type="bool" value="false"/>
    <property name="raise_with_any_button" type="bool" value="true"/>
    <property name="repeat_urgent_blink" type="bool" value="false"/>
    <property name="resize_opacity" type="int" value="100"/>
    <property name="scroll_workspaces" type="bool" value="true"/>
    <property name="shadow_delta_height" type="int" value="0"/>
    <property name="shadow_delta_width" type="int" value="0"/>
    <property name="shadow_delta_x" type="int" value="0"/>
    <property name="shadow_delta_y" type="int" value="-3"/>
    <property name="shadow_opacity" type="int" value="50"/>
    <property name="show_app_icon" type="bool" value="false"/>
    <property name="show_dock_shadow" type="bool" value="true"/>
    <property name="show_frame_shadow" type="bool" value="true"/>
    <property name="show_popup_shadow" type="bool" value="false"/>
    <property name="snap_resist" type="bool" value="false"/>
    <property name="snap_to_border" type="bool" value="true"/>
    <property name="snap_to_windows" type="bool" value="false"/>
    <property name="snap_width" type="int" value="10"/>
    <property name="vblank_mode" type="string" value="auto"/>
    <property name="theme" type="string" value="Default"/>
    <property name="tile_on_move" type="bool" value="true"/>
    <property name="title_alignment" type="string" value="center"/>
    <property name="title_font" type="string" value="Sans Bold 9"/>
    <property name="title_horizontal_offset" type="int" value="0"/>
    <property name="titleless_maximize" type="bool" value="false"/>
    <property name="title_shadow_active" type="string" value="false"/>
    <property name="title_shadow_inactive" type="string" value="false"/>
    <property name="title_vertical_offset_active" type="int" value="0"/>
    <property name="title_vertical_offset_inactive" type="int" value="0"/>
    <property name="toggle_workspaces" type="bool" value="false"/>
    <property name="unredirect_overlays" type="bool" value="true"/>
    <property name="urgent_blink" type="bool" value="false"/>
    <property name="use_compositing" type="bool" value="true"/>
    <property name="workspace_count" type="int" value="4"/>
    <property name="wrap_cycle" type="bool" value="true"/>
    <property name="wrap_layout" type="bool" value="true"/>
    <property name="wrap_resistance" type="int" value="10"/>
    <property name="wrap_windows" type="bool" value="true"/>
    <property name="wrap_workspaces" type="bool" value="false"/>
    <property name="zoom_desktop" type="bool" value="true"/>
    <property name="zoom_pointer" type="bool" value="true"/>
    <property name="workspace_names" type="array">
      <value type="string" value="Workspace 1"/>
      <value type="string" value="Workspace 2"/>
      <value type="string" value="Workspace 3"/>
      <value type="string" value="Workspace 4"/>
    </property>
  </property>
</channel>

Any ideas how to debug WM not starting?

I found this in .xsession-errors.old, which seems to have timestamp of last reboot without deleting xfwm4.xml

/usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
gpg-agent: a gpg-agent is already running - not starting a new one

(xfwm4:1190): Gdk-WARNING **: 17:23:49.860: The program 'xfwm4' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 2700 error_code 2 request_code 151 (GLX) minor_code 24)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
xfsettingsd: No window manager registered on screen 0.
xfce4-panel: No window manager registered on screen 0. To start the panel without this check, run with --disable-wm-check.
No window manager registered on screen 0. To start the xfdesktop without this check, run with --disable-wm-check.
Error connecting to Touchégg daemon: Could not connect: Connection refused
Reconnecting in 5 seconds...
** Message: 17:24:40.461: tray.vala:166: checking updates is not enabled, exiting

I started a new thread for this issue, as this thread is filled with quite a lot that did not solve the problem