Desktop not working on dual Monitor Setup (only on main monitor)

This is probably a dumb question, but I can’t figure this out, I have two monitors, my second monitor works fine, I can right click, create folders, select, but on my main monitor I can’t do anything but add widgets, even if I drag a folder from one screen to another it doesn’t work, even the selection box (when you hold left click on desktop and drag the mouse) doesn’t work.

ik you probably wan’t this


OS: Manjaro Linux x86_64
Host: MS-7A38 2.0
Kernel: 5.15.41-1-MANJARO
Uptime: 7 mins
Packages: 1293 (pacman), 5 (flatpak), 10 (snap)
Shell: bash 5.1.16
Resolution: 1920x1080, 1920x1080
DE: Plasma 5.24.5
WM: KWin
Theme: [Plasma], Breeze [GTK2/3]
Icons: [Plasma], breeze [GTK2/3]
Terminal: konsole

CPU: AMD Ryzen 7 2700X (16) @ 3.700GHz
GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590
Memory: 2120MiB / 16013MiB`

provide formated output, click thic icon in editor: </>
inxi -Fazy
mhwd -l && mhwd -li
find /etc/X11/ -name "*.conf"

I also should mention, cuz I forgot, it happen after I got wallpaper engine for kde, but even when I change back to a normal wallpaper it still doesn’t fix it.

    ~  inxi -Fazy                                                                                     ✔ 
  Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=8e940563-983d-46a2-b759-15b55ec41dea rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B350M PRO-VDH (MS-7A38) v: 2.0
    serial: <superuser required> UEFI: American Megatrends v: A.JQ
    date: 11/29/2019
  Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 2394 high: 4206 min/max: 2200/3700 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2223 2: 1931
    3: 2070 4: 1893 5: 2141 6: 4206 7: 2063 8: 3238 9: 2205 10: 1897 11: 1719
    12: 1893 13: 2162 14: 3532 15: 2150 16: 2987 bogomips: 118441
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Micro-Star MSI driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: DP-3,HDMI-A-1 empty: DP-1,DP-2,DVI-D-1
    bus-ID: 29:00.0 chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,right model: AOC 2590G5
    serial: <filter> built: 2019 res: 1920x1080 dpi: 90 gamma: 1.2
    size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: 24W_LCD_TV
    serial: <filter> built: 2012 res: 1920x1080 hz: 60 dpi: 3048 gamma: 1.2
    size: 16x9mm (0.63x0.35") diag: 184mm (7.2") ratio: 16:9, 16:10 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 570 Series (polaris10 LLVM 13.0.1 DRM 3.42
    v: 4.6 Mesa 22.0.4 direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 2b:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:3 chip-ID: 0d8c:0012
    class-ID: 0300
  Device-4: Trust USB microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:5 chip-ID: 145f:02b4
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.15.41-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp37s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.13 TiB used: 308.47 GiB (26.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: B1D1 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: SA400S37120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 71E0 scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 180.64 GiB (19.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 183
  Processes: 378 Uptime: 4m wakeups: 0 Memory: 15.64 GiB
  used: 2.23 GiB (14.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 1308 pacman: 1293 lib: 358 flatpak: 5
  snap: 10 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.16
    ~  mhwd -l && mhwd -li                                                                            ✔ 
> 0000:25:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:29:00.0 (0300:1002:67df) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
    ~                                                                                                 ✔ 
    ~  find /etc/x11/ -name "*.config"                                                                ✔ 
find: ‘/etc/x11/’: No such file or directory
    ~  find /etc/X11/ -name "*.conf"                                                                1 ✘ 
    ~    

is that wallpaper engine something you installed? if yes uninstall it and reboot and test…

I uninstalled it, and doesn’t seem to change anything. I just got back to the normal wallpapers, but the problem is still here.

there is probably some config left from it
try running this:
rm -rf ~/.local/share/kscreen/*
kbuildsycoca5 --noincremental
then reboot

That didn’t do anything, it just flipped my monitors and it reset my refresh rate, I got it back to normal, but my main problem is still there.

create a new user, and test with it if you still got the same issue

Created new user, and it’s working like it should there, no issue other than my monitor being stuck at 24hz but I know how to fix that since I fixed it on my main.

try these commands:
rm ~/.config/Trolltech.conf
kbuildsycoca5 --noincremental
rm -rf ~/.cache/*
reboot and test with the bad user
if it doesnt help we can reset your plasma settings, and hopefully that will work

nope, didn’t work. If I reset my plasma setting will anything be deleted? like any packages and game saves? cuz I have some and don’t wan’t to lose them.

no it resets only plasma settings, nothing is uninstalled, your game saves are not being deleted … the reseting should help, so that you dont have to copy files like game saves from the bad user into the new user …
so reset your plasma settings:
• Log out of the GUI.
• Switch to a tty with Ctrl+Alt+F2.
• Log in as the user with the problem.
• Issue the following command:
find $HOME/.config/ -maxdepth 1 -name 'plasma*' -exec rm {} \;
systemctl reboot

ok, I can’t do it right now cuz I have to leave, but I will mark it as solved, and thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.