Desktop messed up after using projector


As I was trying to use a projector after a horrible experience (when comparing to Windows on the same machine). The quality and colors of the projection were bad, and that was after I managed to make it work somewhat properly, after going through problems like unidentified projector, resolutions, scaling, buggy windows and so on. Haven’t tweaked much on it other than the graphical interface to make it work.

However, as I finished using it and removed the projector, my desktop theme, widgets, and things like taskbar got either changed, removed and reset.

To added something that may be useful, when using the projector sometimes depending on which screen I’m enabling and active (laptop/projection) either screen or both get changed to another theme ‘dark breath’ the one with the black mountain as wallpaper.

When the projection alone is active and set as primary, my laptop screen change itself to ‘the dark breath’ theme but without anything such as taskbar, just a simple wallpaper. Or I get a completely black screen.

When both the projection and laptop are working at same time, I either get them to work fine with my own theme or changed to the default ‘dark breath’ theme with a taskbar and things unlike in the previous example.

So I think a bug occurred and made my desktop stuck at one of the bad state when he was using the projector. The one with just a wallpaper of the default ‘dark breath’.

I tried to fix it myself using my shallow knowledge such as :

  • Playing with the display and monitor graphical settings (system settings - Hardware - Display and Monitor) with and without the projector connected and rebooting frequently.

  • Using keyboard hotkey to change displayed screen (fn+f4)

  • Connecting to a second monitor

  • Restarting Plasma shell with this command : killall plasmashell && plasmashell --replace

  • Adding back taskbar panel and widgets manually with a right click in the screen, but noticing some awful differences such as the lost content of my sticky notes, lost taskbar icons shortcut, favorites list of software still exist but not sorted alphabetically…

  • Changing/resetting appearance and theme, nothing fixed.

  • I tried changing kernel but still nothing fixed.

  • Switching between wayland and x11 didn’t help. I was using wayland at first.

  • I also tried to use the ‘highlight changed settings’ to find a potential clue but everything seems as it was.

  • Root session works fine, thankfully nothing changed there as far as I remember.

  • I looked into the config file of the plasmashell (.config/plasmashellrc) and here is the output for my first and only main user beside root:

nano .config/plasmashellrc

[KFileDialog Settings]
Recent Files[$e]=file:$HOME/Pictures/Wallpaper/wallhaven-p2le2p.jpg,file:$HOME/Pictures/Wallpaper/wallhaven-0wel8r_1366x768.png,file:$HOME/Pictures/Wallpaper/wallhave>
Recent URLs[$e]=file:$HOME/Pictures/Wallpaper/

eDP-1 Height 1366x768=464
eDP-1 Width 1366x768=371


[PlasmaViews][Panel 2][Defaults]

[PlasmaViews][Panel 2][Horizontal1024]

[PlasmaViews][Panel 2][Horizontal1366]

[PlasmaViews][Panel 2][Horizontal1600]

[PlasmaViews][Panel 2][Horizontal800]

[PlasmaViews][Panel 35][Defaults]

[PlasmaViews][Panel 35][Horizontal1366]

[PlasmaViews][Panel 37][Defaults]

[PlasmaViews][Panel 37][Horizontal1366]


  • Here is the output for root session : (they are quite different, should i try to replace the below plasmashell config file into my main user?)
nano .config/plasmashellrc

[PlasmaViews][Panel 2][Defaults]

[PlasmaViews][Panel 2][Horizontal1366]


The performance seems slower now I think and sometimes once a hour or two, my laptop shutdown by itself like in sleeping or hibernating mode, after starting it again I find myself in the locked screen but with my work saved.

I can probably just start using this desktop as it is and added things back but I’m fearing bad/broken things that I wasn’t able to notice and their future repercussion. Also it feels just like I’m using my laptop in a buggy state so I feel unsafe.

Here is the output of my system information:

inxi --admin --verbosity=7 --filter --width

  Kernel: 5.16.18-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=61585b2a-2bcc-4917-bb6f-effe048aad57 rw quiet apparmor=1
    security=apparmor resume=UUID=92b30871-9c03-49ae-9745-aacd680b67f5
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP ProBook 640 G3 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 82AA v: KBC Version 49.35 serial: <superuser required>
    UEFI: HP v: P83 Ver. 01.06 date: 07/07/2017
  ID-1: BAT0 charge: 14.6 Wh (40.0%) condition: 36.5/36.5 Wh (100.0%)
    volts: 11.2 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: discharging
  RAM: total: 7.64 GiB used: 6.5 GiB (85.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xEC
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1717 high: 2100 min/max: 400/3100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1319 2: 1703 3: 2100
    4: 1746 bogomips: 21607
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
  Device-2: Lite-On HP HD Camera type: USB driver: uvcvideo bus-ID: 1-9:4
    chip-ID: 04ca:7063 class-ID: 0e02
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x2e3c built: 2013 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.8
    direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.18-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:2 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 250.88 GiB (53.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM021-1KJ152
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: YXM1 scheme: GPT
  Optical-1: /dev/sr0 vendor: hp model: DVDRW GUE1N rev: UE00
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 80 GiB size: 78.19 GiB (97.74%) used: 40.24 GiB (51.5%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 61585b2a-2bcc-4917-bb6f-effe048aad57
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 35D2-4F39
  ID-3: /home raw-size: 373.26 GiB size: 366.33 GiB (98.14%)
    used: 207.3 GiB (56.6%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 26025d40-e699-4da8-93eb-f942d2e7c820
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 12 GiB used: 3.33 GiB (27.8%)
    priority: -2 dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: 92b30871-9c03-49ae-9745-aacd680b67f5
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2a class-ID: e001
  Device-2: 1-8:9 info: Validity Sensors VFS495 Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 138a:003f class-ID: ff00 serial: <filter>
  Device-3: 1-9:4 info: Lite-On HP HD Camera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04ca:7063
    class-ID: 0e02
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 39.0 C pch: 35.5 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
  Processes: 244 Uptime: 1h 49m wakeups: 8 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1669
  pacman: 1662 lib: 441 flatpak: 0 snap: 7 Shell: Zsh v: 5.8.1 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.15

I’m all ears for any solution, the goal here is to revert things to how they were for the best case (Sadly, I disabled timeshift). Else, a way to truly resetting my dektop and making sure I’m using a clean and safe working desktop (without reinstalling manjaro, deleting my data or breaking more things…).

Potential solutions I thought of :

  • Creating a new user and switch over. (albeit I forgot the risk of such process, it’s alright if i lose little things such basic settings, but what important could I lose from it? Like my data, software or access to them? I think I can just copy my browser config folder to my second session if it’s not there already, but what about some software config, do i need to copy them? And I wonder if most things are going to work just fine without breaking because i installed them with the old user? My Manjaro is rather a new installation with less than two months this time with this laptop. So haven’t done much with it yet.

  • Deleting some caches or/and files in .config folder or somewhere else to reset, if there is a guarantee of not losing data of course.

  • Replacing some files or config with from a working new user session or root, maybe like said previously with the plasmashell config file?

first try go to system settings/appearance/global theme click ‘defaults’, click apply
then clear your cache with:
rm -rf ~/.cache/*
reboot and check

Currently there are mutliple bug tickets open upstream ( with regards to mutliple monitors and loosing settings, wallpapers and/or black screens.
Environments with changing setups (monitors sometimes present, sometimes not) seem to be more likely to be affected. For some setups problems arise even when a monitor goes into standby and wakes up again.

See for example:

Thank’s for your reply. I have done the first step as instructed, is there a second step?

For the results I didn’t get back my old desktop as it was, might be obvious since we only proceeded to delete cache and get back the default theme.

Speaking of the default theme, I noticed that the color of the windows and Dolphin changed to the default white, however the background wallpaper is still using the black mountain even tho it should be using the default ‘breath’ theme with the white mountain wallpaper.

Is it not a sign of a bug or partial failure? One widget remained (blank sticky note) and softwares still not sorted correctly in favorites. there still an icon which is blank in task bar and another unnaturally deviated by some distance.

As for the deletion of my user cache, there was a little error at first because of the browser and that also spared six other folders, so I did it a second time and everything was deleted. But my browser (brave) history and profiles still remains after rebooting even tho it should(i think) have been deleted in the cache, that’s why I did a backup in case.

Dunno if those are signs of failures or not. Do you think it’s alright and safe now for me to invest my time on it? Or is there a second step or a way to confirm the safety?

Thank’s for your reply, that was helpful.

I hope such bugs get fixed in the future updates. When it breaks aside, I like Manjaro very much.

And it would be good if such bugs just affect temporary the visual theme of the desktop, I’m more concerned of it affecting settings, data or performance. It’s good if the problem is just simple and noticeable but it’s of greater issue if the problem/bugs are hidden and not eye-catching.

Right now, I just tried to choose the default ‘breath’ theme with the option ‘use desktop layout from theme’. So that it can reset properly the theme and even delete hidden panels if there are.

The good news, that my desktop seems cleaner and smoother, blank and deviated icons (spread some distance from each other) on the taskbar got removed and fixed. Also the softwares in Favorites got correctly sorted as they were.

I wonder if this is enough and fixed?

so do you have still some issues? its not clear to me

I had, before including a new layout from a theme. In the noticeable level it seems to work fine now. I was just asking if my ill-fated relation with this problem came to an end. And if there is a good way that i’m not aware of to verify that.

you could also try running this, just to be sure:
rm ~/.config/Trolltech.conf
kbuildsycoca5 --noincremental
clear cache again:
rm -rf ~/.cache/*
and do you have access to the projector right now?

Alright. And as for the projector, yes i can have access to it now. Even tho I would prefer to avoid using it and attract problems to me again (it was for a friend-presentation before).

i thought you planning it to use regularly … so you try connecting it, but disable the compositor before with: alt+shift+f12 and see if it gets messed up again with disabled compositor… if not, then enable compositor again with the same shortcut and try disconnecting the connector, and see if it gets messed up

How to know if the compositor is getting disabled/enabled? There doesn’t seem to be any change. As for the projection, the scaling, resolution and quality are still bad. But the desktop is not getting messed up, I think the issue may come up again if I try fiddling with the projection and screen display configuration like before.

you dont have any desktop effects if its disabled, also no animations… etc… so if you pressed the keys, the compositor got disabled, if you press them again it gets enabled… thats what i wanted you to try, to disable the compositor, connecting the connector and setting it up, then disconnecting it, enabling the compositor and check if the desktop get messed up again… just to narrow it down…

I enabled the ‘Woobly effect’ and started using the shortcut alt+shift+f12 to enable/disable compositor (it’s even setup as such in my shortcuts), However if the process is usually quick/instantaneous then the window woobly effect is not getting disabled no matter how many times i use the keyboard shortcut. Also no notification.

I’m currently using the wayland session, when going to the compositor under System settings. Unlike in the past (few months ago) there are only three options there :

  • Scale method
  • Latency
  • Tearing prevention (vsync)

you are using wayland, so thats why you cant disable the compositor… did you were using wayland when your desktop got messed up?

Yes, when first using the projector I was using the wayland session, and everything got messed up there. Afterward, I tried to change to x11 as explained in my post, but nothing got fixed there.

Lastly, I tried the first part of your commands to fix my problem (clean cache and default theme) in x11.
Then the second part (clean cache, removal of trolltech config and the command kbuildsycoca5 --noincremental) in wayland.

wayland is still buggy on kde - glitches, lags, all kinds of graphical issues… and after your desktop got messed up, switching to x11 would not solve it… so switch to x11 and use it, and try the projector with it

I see. well, i switched to x11 and the compositor can be turned off. Also the projector still haven’t messed up with the desktop.

so it was probably because of wayland… you could also try it out with compositor enabled …

Already did I think (if it was correctly switched). Perhaps it was indeed because of wayland.

I think it’s time to conclude this topic as solved. Thank’s to both of you.