Desktop is damaged after Updates yesterday - 20211120 - no Dock, no Move, Resize etc. of Program

i uses the Deepin Edition of Manjaro.
Yesterday I did update the System 2021-11-20

After this I have some issues.

  1. After Logon no Dock is comming up

  2. if I open a Pogramm over Terminal for Example Firefox, FileManager
    can no resize move etc.

How can I fix this?

I created a new User1 there is the same issue with
moving, resize etc. a Program

Dock came after login on this user…sometimes

1 Like


Deepin seems to be in a broken state. In order for me to have the dock, i actually have to restart the WM with
deepin-wm --replace &
otherwise i have just an empty desktop and i can access the right click menu only.
GTK+ apps have no title bars, nor window decoration to resize them, and Qt apps are inmutable …

Unless there is a known issue upstream and a fix there, i don’t see how you could.

but deepin-wm did not exists.

try to install an reboot…

install deepin-wm did not help…
can not move, resize etc. the programm windows

but the dock is there now…

ok need to run deepin-wm --replace &

then the move, resize work,

thank you!!!

can some explain how to do it

Same Problem here. Starting deepin-wm helps as temporary hack, but it needs to get fixed.

Well … talk to deepin. Its basically always broken, always has been, and their releases are a bit chaotic.
Also - dont expect much. Even though its ‘open source’ they dont seem to put a high priority on transparency or interaction.
If none of that, or the bugs that come with it, are acceptable to you … you should use a different DE.


“Its basically always broken, always has been”

This is not true! I have been using Manjaro DDE for more than a year now … and the experience has been good. It is true that the 20211120 updates broke DDE but the fix above makes things usable again.

What I had to do …

sudo pacman -S deepin-wm

then run

deepin-wm --replace &

I also ran

sudo deepin-wm --replace &

Thanks to bogdancovaciu for the advice!

Below is what terminal spews when the deepin-wm --replace & is given … maybe this can help someone find the bug

(deepin-wm:1254): GLib-GObject-CRITICAL **: 15:55:09.959: g_value_set_boxed: assertion ‘G_VALUE_HOLDS_BOXED (value)’ failed

(deepin-wm:1254): Gtk-WARNING **: 15:55:10.027: Theme parsing error: gtk.css:3611:22: ‘none’ is not a valid color name

(deepin-wm:1254): GLib-GObject-CRITICAL **: 15:55:10.090: g_value_set_boxed: assertion ‘G_VALUE_HOLDS_BOXED (value)’ failed

(deepin-wm:1254): Gtk-WARNING **: 15:55:10.198: Theme parsing error: gtk.css:3611:22: ‘none’ is not a valid color name

** (deepin-wm:1254): WARNING **: 15:55:11.690: DBus.vala:44: Could not acquire name

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2e0000a (Terminal)

1 Like

It is a community edition, so I expect that someone checks, that a major update don’t break the system. I don’t know why you blame the deepin team in this case. I know about the history that at some point manjaro discontinued deepin, but now its back at least as a community edition. I see its not an official edition, but after installing XFCE edition first I decided that this is really ugly in many respects and that I take the risky road again. Since deepin-wm is officially discontinued we need another solution.


thx it works have deepin back again

1 Like

Noob question, is it possible to temporary roll back as workaround? If possible can you give some directons? Many thanks, next time will read before updating

I had the same issues above, and tried multiple restores with Timeshift - the earliest snapshots did not solve the issue however one saved just before latest update when things broke worked - I lost quite a bit of set up (new machine) as I have been trying to find a working system of safety and convienience. Unfortunately Timeshift does not appear to support NAS or network locations - so I only had limited local drive space and it fills up quickly with daily and weekly snapshots. But Yes rolling back to a previous snap shot saved me.

I wonder which package is to blame. It seems to me that the basic deepin stuff has not changed with the update, neither lightdm. So how can this happen? The deepin-wm solution may stop working soon, as the package is deprecated.

Then dont use deepin.
Its that simple.
Why do folks just wish to ignore it is, has been, and probably will be buggy?

Desktop is damaged after Updates yesterday - 20211120 - no Dock, no Move, Resize etc. of Program - #8 by cscs :arrow_heading_up: :arrow_heading_up: :arrow_heading_up:

Then you fundamentally misunderstand what a community edition is.
It does not mean manjaro supported.
It just means that someone from the community whipped up an ISO using manjaro without fundamentally changing the base structure or packaging system etc.

So do you use manjaro-deepin?

new update on deepin or any manjaro stuff today
but deepin is still ■■■■■■■ broken THX
sry but frustraded that its al broken i do like deepin
gezz have too get use to mabox

If someone still has this bug, you can also autostart deepin-wm by just copying /usr/share/applications/deepin-wm.desktop to ~/.config/autostart/

This might also be a kwin problem instead of a problem just with Deepin. I dunno.

thx but Know idear how too do that

  1. Open terminal.
  2. Install Deepin Window Manager with sudo pacman -Syu deepin-wm. Enter your password and wait for it to install.
  3. Copy the file by: cp /usr/share/applications/deepin-wm.desktop ~/.config/autostart

Hope it works for you too.

Para solucionar el tema que aquí se trata hice lo siguiente:

  1. sudo pacman -Syyu
  2. sudo pacman -Syu deepin-wm
  3. sudo deepin-wm --replace &
  4. cp /usr/share/applications/deepin-wm.desktop ~/.config/autostart
  5. Fui a: ~/.config/autostart y marqué “Deepin Window Manager” y tildé “Ejecutar como programa”.
    -No es un descubrimiento, es el resúmen de lo que aquí se ha dicho. Gracias a todos.
    PD. No he logrado cambiar el fondo de pantalla…

Thank you CSCS, I had a simple question implicit in my post - trying to find a working (arch based) system… I use a few key applications, Appimages, have recent hardware, and two 4K monitors, as well as normal ancillaries like printers etc, and on about 20 different distros, Deepin Manjaro was the only one that worked for me. A rolling or semi rolling release was also on my wish list.
I am a Noob, don’t wish to spend most of my time fighting with the terminal to get things done, Deepin worked out of the box for me - rarely does that happen for me.