Desktop files are not showing

I’ve saved some files into my ~/Desktop folder, and the only way I can access it is by the file explorer. The files are not showing up on the desktop. The desktop wallpaper is still showing, but when I click and drag nothing happens (I expected a selection rectangle to appear) and when I right-click there are no options for creating files, etc.

Is this an intentional feature? And how do I make the desktop display files from the ~/Desktop folder?

This is the way GNOME is designed. There are no files or icons displayed on the desktop.

Install the Desktop Icons NG GNOME Shell Extension. It’s in the repos as gnome-shell-extension-desktop-icons-ng.

1 Like