Desktop environment (Plasma) won't launch!

Yikes, I seem to have screwed things up pretty badly. I’m running a Manjaro Linux installation, and a couple days ago I switched my desktop from Mate to Plasma. But I noticed two annoying things:

  1. The login screen was still using Mate’s display manager, not SDDM.
  2. The desktop was defaulting to Mate, and had to be manually changed to Plasma on every login.

So today I had the “bright” idea of simply deleting Mate’s display manager, thinking that would force the OS to revert to using SDDM.

Nope! Instead, I now have no desktop at all, just terminals. I can log in on TTY1 through TTY6, on any of 3 accounts, and do anything that can be done via terminal, but ctrl-alt-F7 does gives just a black screen.

Stuff I’ve tried so far to no avail:

  • I tried uninstalling Mate entirely; problem persists.
  • I tried reinstalling Plasma; problem persists.
  • I tried launching SDDM manually by just typing “sddm”, but the results are bad: The SDDM “Maldives” login screen launches, I log in, the animated splash screen launches, a mouse pointer appears, then the animation freezes and I’m just left with a frozen splash screen and a mobile (but useless) mouse pointer.

So, how can I tell the OS, via command line, to start a SDDM desktop session (on TTY7, presumably)?

Update, 30min later: I was able to get back in! I had an epiphany: SDDM is “service” based, so may not work right if not launched as a service. So I typed “systemctl start sddm.service” and a normal SDDM service launched. Everything in the desktop appears to work. But it’s on TTY1, not TTY7 (as I think it should be, no?). So the question remains, how can set SDDM to start on TTY7 on system startup, instead of me having to first login on the TTY1 command line and manually type “systemctl start sddm.service”?

Don’t worry.

Once you mess it up this way, there’s a very simple solution… faster than reading and answering your post!

Get your USB, do a clean fresh install of your KDE.
Launch Timeshift and restore your last snapshot.
Restore your backed up data.

Takes about 30 minutes - back to the way it was before you installed Mate!

Optional: Install and use SDDM, the recommended display manager for KDE

SDDM is installed as a dependency of plasma. To enable it

systemctl enable sddm.service --force
systemctl reboot

Install Desktop Environments - Manjaro

1 Like

Re “clean fresh install”: Yikes. That does not sound “simple”, “fast”, “30 minutes” (more like 20-30 HOURS), safe, or even guaranteed to result in anything good happening. Especially seeing as I can now reliably start the system (I’m using it right now), albeit with 2 extra steps:

  1. Turn-on computer.
  2. Enter BIOS password.
  3. Select “Manjaro Linux” on Grub menu.
  4. Log into TTY1 as root. (EXTRA STEP)
  5. Type “systemctl start sddm.service” (EXTRA STEP)
  6. Log-in on SDDM login screen as my regular user.

I’m just asking about how to get rid of steps 4 and 5 in that procedure (should be automated but isn’t). I’m pretty sure it has to do with “display-manager.service” being a symbolic link to “lightdm.service” (which doesn’t exist) whereas it should be a symbolic link to “sddm.service” (which does exist). But I don’t know where that file is located.

Re “the way it was before you installed Mate”: Before I installed Manjaro-Mate, this computer was Microsoft Windows 10. (And before that, Windows 8.) Nope, not going back.

Nor am I interested in going back to Mate. Nope, Manjaro-Plasma is working just fine for me; I just need to find a way to auto-launch sddm on tty7 on startup. Probably it’s that broken symlink I mentioned, if I can find the darn thing.

I actually found that page a few hours ago and tried that, but I got a barage of bizarre error messages:

%systemctl enable sddm.service --force
Failed to enable unit: Unit file --force.service does not exist.

%systemctl enable sddm.service
Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is a symlink to /usr/lib/systemd/system/lightdm.service.

Hmmm. There’s the problem. I need to edit that symlink, as “lightdm.service” does not exist (I uninstalled it) and is not what I want to use (I want “sddm.service”). Let’s try…

%ln -snf /usr/lib/systemd/system/sddm.service /etc/systemd/system/display-manager.service

%systemctl enable sddm.service


Well, what do you know, no errors this time. :slight_smile: Hmmm. I’ll reboot and let you know if that worked.

You should properly disable lightdm, before enabling sddm.

systemctl disable lightdm

Or rather, since it touches at system services, you may require superuser privileges:

sudo systemctl enable sddm --force
1 Like

Update, a few minutes later: It works! :smiley: Still on TTY1 instead of TTY7 (kinda weird), but maybe Plasma just does it that way? Dunno, I only have about 1 day experience with Plasma. But my desktop is now fully functional, which is what matters. Thanks for the tip.

It should start on TTY7 like any other DM. Maybe it doesn’t in your end because of all the roundabout…

My guess is that you’re running a ZX Spectrum.

If I boot a USB it takes less than a minute to load a desktop, then installing takes no more than 6 minutes.
After a reboot (which should now work) I can start up Timeshift, and that takes about 20 minutes to parse a list of files, and then move them to my installation - then rebooting brings me back to my familiar theming/layout etc of my previous KDE desktop.

After that, I can launch back-in-time to bring personal files back to the /home folders. This takes around 10 minutes.

It also guarantees undoing everything that got messed up when you started installing another desktop (slightly more reliable than trying to do it manually - how much can you remember from the massive list of installed apps?)

Well, kinda late now, as I completely deleted lightdm. :slight_smile: But lets see what happens when I disable a nonexistant service:

%systemctl disable lightdm.service
Failed to disable unit: Unit file lightdm.service does not exist.

Now THAT is a direct, succinct, concise error message. :slight_smile: I rather suspected the OS was going to say that, seeing as how I explicitly uninstalled first lightdm, then mate.

Water under the bridge now, as I’m moving forward with Plasma only. (Well, expect for a few bits of Mate that didn’t get uninstalled, such as I now have 2 different Bluetooth monitors in my system tray. I’ll have to remove the remaining vestiges later; I’m just glad to have my desktop back.)

Re “ZX Spectrum”: Sounds like a brand of car. :smiley: But no, I have no idea what that is.

Re “boot to a USB”, in your earlier comment I thought you meant “install Manjaro-Plasma over existing Manjaro installation”, which would wipe out certain files (eg, “/etc/fstab”, “/etc/bash.bashrc”) which probably aren’t backed-up anywhere (I need to do new snapshots of my “/” and “/home” partitions; my backups are old), hence my “20-30 HOURS” estimate. (40-80 hours if “/home” also gets obliterated.)

Re “Timeshift”, while I’ve heard of it, and I think it’s installed on my machine, I’ve never used it and I know NOTHING about it. I should probably learn, yes, as I’ve been told it’s Linux’s primary way of doing backups. So far, I’ve been doing backups with Aomei Partition Manager (for whole-partition snapshots of bootable Windows and Linux partitions) and FreeFileSync (for keeping multiple copies of my data partitions on two different computers synced; ie, computer 2’s /c /d /e partitions are mirrors of computer 1’s /c /d /e partitions). But I should add Timeshift to my arsenal; thanks for goading me in that direction.

There are two main kinds of backup. Timeshift is good for system restore, not so great for complete restore - it overwrites all your files (so any work you did will get overwritten with old files).

So you set Timeshift with mostly normal settings, backup /home and hidden stuff, but enter omissions… for example, my Plex CACHE folder has a million tiny files - not needed.

So I excluded that, and my guayadeque (includes tons of podcast data) and Dropbox which is stored in the cloud.
Timeshift is set to save to another disk - so /mnt/T3/Timeshift folder is where that goes - it keeps 2 monthly, 3 weekly, 5 daily snapshots.

Then Backintime catches the rest… so when my PSU exploded and I had to buy a new motherboard and change from an older i3 to a newer Ryzen 5600G, the whole setup (install, restore) took 30 minutes…

Then tweaks take a bit longer, editing conky and a few other configs… but the system basically worked fine after 30 minutes - torrents still seeding as if nothing happened.

As you already have most files backed up, Timeshift would just give you a very quick way to restore the system files and .config stuff back to root and /home.

Traditionally the GUI was on F7, and still is for most, but KDE and Gnome like to be different.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.