Desktop effects have been suspended KDE Plasma

Hello guys
When I connect my external monitor to my laptop using HDMI to VGA connector I get the notification from KWin Window Manager: “Desktop effects have been suspended by another application.
You can resume using the ‘Alt+Shift+F12’ shortcut.” and of course effects are disabled. When I use the shortcut ‘Alt+Shift+F12’ nothing changes still no effects only solution is to restart the system which is very inconvenient and annoying.

Seems like your compositor is turning off when you plug in the other monitor.
(why? I dont really know)
I guess one quick shot would be turning off the “Allow applications to block compositing” setting, which might stop the disabling in the first place.

That Compositor is killing my nerves too, whatever I adjust, it is auto switching off sometimes when I “too quickly” reactivate the screen edge functions in KDE, especialyl when I set lower than 150-350ms activation time and especially with lover than 800-1000ms reactivation time. And KDE cannot blame my weak RTX2070 VGA card or 8700K CPU for this, okay I guess they could blame the Nvidia prop driver but that Runs ARMA3 FPS game in 4K here on Linux without crashes so a desktop shall be fine

Tried disabling Allow Applications to block compositing but no use still lose effects after plugging/unplugging external monitor

I don’t have such powerful hard but KDE and Gnome are such nerve killers for me as well. Too many modules that usually crash or don’t work properly and it seems those are common problems not only in my case. I hope those issues will be fixed in the next builds maybe before that I should try XFCE which is lightweight with less problems.

1 Like

According to my short but intense experience with Linux, after installing like 15 distros with all major desktop systems in countless variations on my four very different PCsn, Gnome clearly does have the most issues, very serious and fundamental ones on many distro/Pc combinations while the simplest XFCE may be one of the most fail safe and hassle free and KDE on stable distros is quiet fine too with minor annoyances. I still laugh at Xfce and dislike it because of its 1995 look, feel and solutions and KDE offers the most customization as far as I see which is fundamental to make an Os fit to everyone, young and old, tech savvy and non tech people who just wanna enjoy life and the Os as a tool.

2 Likes

I’ve just been using linux for several months. Only tried manjaro on my laptop. At first installed gnome which was the most problematic as you mentioned. KDE is really fine and I’m already used to it because of customization and tools but sometimes it makes me think of gnome with problems, but it’s way easier to fix them. XFCE’s look isn’t amazing for me as well (I installed a couple of distros with XFCE DE on virtual box)

1 Like

I ran into the same problem earlier this year and managed to find a workaround which might help you as well:
In System settings - Workspace Behavior - Desktop Effects enable “Background contrast”.

I still don’t know how and why that works but it helped me and hopefully will be useful for you as well. :slightly_smiling_face:

1 Like

I don’t know how or why but it works. That’s the weirdness of KDE/Gnome :smiley: :smiley:
Thank you

by gosh thats an odd one.
Be sure to check after the next big plasma release.
(I wonder if a bug report has been filed about this…)

I’m really glad it worked for you just like it did for me. :relaxed:

If I’m not mistaken, this should be the associated bug report. :thinking:

when is it planned the next plasma build to be released?