Desktop Effects are being disabled in 5.21

the KDE version of Arch is vanilla, so YES

So it could be a KDE problem after all if enabling this KDE settings, like on ARCH, fixes the issue? (//EDIT2: also another test is to disable this desktop effect on ARCH, and see the result, but this is not convenient).

//EDIT: but to stop wasting time, just enable the desktop effect and see by yourself before getting to conclusion, we can guess and make assumption all day but this is not going far.

The Desktp effect is permanently activated by default!

But well, I’ll just put it on the list of problems I obviously have to live with …

I don’t understand your replies. Anyway I’ll stop replying, both of you just test and report.

//EDIT: just test and report TO ENABLE THE DESKTOP EFFECT IN YOUR MANJARO INSTALLATION TO SEE IF IT FIXES THE ISSUE (not in ARCH, I knew I wasn’t crazy, your replies make no sense lol).

I don’t have Arch installed anymore at the moment, sorry

So far, after changing the compositor rendering backend from OpenGL2.0 to OpenGL3.1 and also enabling “Background contrast” under desktop effects as previously suggested by lovely induviduals, I haven’t experienced this issue again.

Nice! thanks for trying and reporting back. But stay on your guard, try to ‘force’ the issue to replicate now, see if you can find ways to trigger this issue. If by trying you fail, then it can increase the confidence about the resolution of the issue. But I’m pretty sure enabling this desktop effect is the solution for most of these ‘desktop effect have been disabled’ issues.

Maybe that wouldn’t be a bad idea to have this enabled by default in Manjaro (will open an issue on Manjaro’s gitlab), I could see no difference with or without this desktop effect, besides resolving the issue that many people had.

So thank you for keeping this thread going.

I’d like to chime in and share a “solution” I’ve discovered.

I noticed that desktop effects were disabled whenever power saving feature was “interrupted.”

So as I said in my post, screen off at 10 min, sleep at 15 min.

Screen-off never worked right for me for a long time (definitely pre 5.21, but can’t say when). Screen would flicker after 10 min, but come back on, and then go to sleep with the system at 15.

I noticed one time when I sat down at my computer just as the screensaver was being turned “on,” that as it flickered, desktop effects were disabled.

If I deactivated screen-off and just left sleep (main pwoer saving feature) activated, desktop effects are working fine for me for several days now.

Another data point (though its sporadic) is I have qbittorent set to over system sleep…the same thing happens with it (I think, as I don’t torrent too much so I can’t say with certainty). If qbit goes on for long enough, system begins to sleep, qbit itnerrupts and keeps system awake.

From a user point of view, what I see is the screen temporarily flicker.

But again, desktop effects are disabled!

There’s something of value here, maybe poeple who know more than me can use it to debug.

But the solution for me has been: deactivate screen-off and only rely on sleep