Desktop Effects are being disabled in 5.21

The moment I upgraded to Plasma 5.21, I noticed that after my computer wakes from sleep, desktop effects are disabled.

I just did a fresh install of Manjaro and did nothing except enable sleep in the power settings.

And Desktop effects are being disabled in a fresh install

Can others verify this? Why is it happening and more importantly, how can I fix it?

Yup that is a solution; however given how many times my computer goes to sleep, it gets real tiring.

Especially also considering of how its a Manjaro specific problem, I was hoping to diagnose it a little bit. Or at the very least see if other people are experiencing it (I’m only experiencing this issue in Manjaro).

If this behaviour does not exist for a fresh user, you can look into configuration related troubleshooting.

But that’s just it, it is happening on a fresh install.

And only on Manjaro, not on any other distros running kde (at least for me)

Could be driver related? Could be default KDE settings with your video card not playing well?

That’s definitely a possibility. But I have an amd gpu and thus am using open source drivers.

If drivers were an issue, wouldn’t it also appear on other distros?

1 Like

Only thing I (with Plasma 5.21, amdgpu) noticed recently is desktop effects (or rather compositing) being disabled when plugin in a second monitor the first time after a reboot.

I can enable them again by hotkey, or by signing off and on again, it’s really just the first time I plug in the 2nd monitor.

There is a long lasting plasma bug open for disabled compositors when using an external monitor.
https://bugs.kde.org/show_bug.cgi?id=394890

2 Likes

Hello helpcomputer,

I have just recently installed Manjaro 20.21 with KDE Plasma 5.21.4. Did you by any chance install Manjaro without a swap partition? The symptoms you describe are similar to what I have experienced when my MacBook Pro 15" (Mid 2015, i7 Quad-Core 16GB RAM) goes into a sleep state. This does not happen in Linux Mint or two BSDs I use on the same machine.
I fear you may be right in that this problem is specific to Manjaro. In my case, I have un-ticked the option to sleep and the woes go away. But I appreciate this may not be a solution for everybody. Perhaps it will be fixed in an up and coming update…hopefully.

I have a pretty plain setup (single 1080p monitor, no scaling, nothing.)

Yup Dino-Fossil implied the same thing, but I’m just running a single monitor setup, and its not even a high-res monitor or anything funky.

Interesting; I’ll try that and give you an update in a few days.

So two reasons why I’m hesitant of sticking with that (I’ll dfeinitely do it to test it out)

1.) I kind of need a swap partition (not enough ram, only 8gb)

2.) I put my computer to sleep really often. I’m away from my computer quite frequently and it just seems like a massive waste of power to have it running, doing nothing. So it just doesnt’ seem like an enviornmentally conscientious decision to leave it awake.

Hi all,

I’ve recently switched over to Manjaro too and have the exact same problem.

Everything works fine in this beautiful OS except after sleep, desktop effects don’t work.

Pressing alt+shift+f12 makes them work again, but this isn’t a permanent solution.

By the way, mine occurs on a fresh install too, so I believe this is a bug.

I’ve currently installed the latest AMDGPU drivers and everything works as expected. All my programs are utilising the driver properly, sleeping and waking works fine, gaming works, video editing etc.

I only have one 1080P monitor connected to my RX590 over HDMI.

I also believe this is Manjaro specific as I didn’t get this behaviour when I was on a debian based system previously.

Anyone have any further ideas?

Did you guys at least try to enable background contrast effect in the desktop effects? This is a fact that without this enabled, there are issues like this one, even if you don’t have multiple monitors.

Here is the related bug, even if you don’t have multiple monitors.

I’ll give that a go if it persists, cheers!

Right now I just found and changed the rendering backend from OpenGL2 to OpenGL3.1. I slept my machine several times and compositor still works after waking. This seems to have solved it on my machine.

Good for you if it is true. I doubt it though, I had this issue with desktop effects disabling themselves and I also though OpenGL 3 was the fix, until it happened again. Only ENABLING this specific desktop effect solved the issue on my end (an on many others’ end).

1 Like

For me, it doesn’t need a hibernation state either. It occurs, for example, when the computer is ventilated overnight with the monitor off (long download or similar). When I turn the monitor back on in the morning, the effects are gone. As for the hope for an update: I’m running Plasma 5.22.3.

Right, on Arch I NEVER had it in several years.

Does Arch have this desktop effect enabled by default?