Dependency fail on manjaro-gnome-assets

failed to prepare transaction (could not satisfy dependencies)
:: removing gnome-shell-extension-gsconnect breaks dependency 'gnome-shell-extension-gsconnect' required by

I can’t remove gnome-shell-extension-gsconnect. I want to install the gsconnect code from the source.

Install gnome-shell-extension-gsconnect-git from the AUR, then. :wink:

I worried about having 2 competing versions running. Also, the *-git version in the AUR repo looked older (I know, right?). Anyway, I managed to uninstall version 44 from my machine using pamac (wasn’t happening under yay -R) and tried to install gsconnect from source. I ran into some python issues which cleared up when I updated my system.
It looks like my original issue (not receiving SMS notifications on my desktop) lay in my phone. I needed to grant Android permissions to the app to handle my SMS messages. Also, I had to grant access on my phones file system for downloads and mounting.
All fixed up now. I’m running the git code from github because I didn’t get my repo installation working. I hope that this contributes to the body of knowledge. Try not to lose this forum too.

There wouldn’t be. gnome-shell-extension-gsconnect-git provides and conflicts with gnome-shell-extension-gsconnect. You can only have one installed at a time.

Now that’s where you get into competing versions and conflicting files. It’s not wise to install programs without Pamac / Pacman as they can’t be tracked and you will run into these problems. I know you uninstalled the repo package first, I’m just letting you know. :wink:

The gnome-shell-extension-gsconnect-git package needed some stuff from base-devel. I installed all of base-devel and by carelessness included AUR. I ended up in SELinux territory. PAM was uninstalled in favour of SELinux-PAM and 2 others that I can’t remember. It was a mess. And after all that, gnome-shell-extension-gsconnect-git installed but I didn’t get it running. I can’t remember if I restarted wayland-gnome by then. That’s how I ended up installing from github and not AUR. Also, it looked like AUR was behind by a few versions.
I think that such popular software such as GSConnect should get more love from this distro.

Yes, the base-devel group is required for using the AUR. Apparently you have some reading to do.

I have no idea about the rest of what you said, it has absolutely nothing to do with anything related here.

What does that even mean? It’s up to date in our community repo and included by default on GNOME ISOs. I use it every day and it works fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.