Dell XPS15 9560 is heating more on Manjaro than on Windows with the same apps open

Hi everyone!

I’m new to Manjaro and I’ve switched to Linux because I’m learning programming.

I come from Windows and when I open on Manjaro all the apps I normally use, the laptop starts to heat more and the fans increase their RPMs (over 4000 RPM)

The things I did to optimize:

  1. For graphics cards I use the “video-hybrid-intel-nvidia-450xx-prime” driver - which I understand is able to use Nvidia GTX 1050 only when it’s needed.

  2. I installed TLP-UI and set up the CPU Energy to “balance_power”

  3. Set up fans mode to balanced with:
    smbios-thermal-ctl --set-thermal-mode=balanced

Overall, the memory and CPU usage seems lower on Manjaro than Windows so I don’t understand why it’s hotter and fans make more effort on Manjaro than Windows.

It could be that I use a Windows trading software with Wine? it seems to significantly increase the CPU temperature when I open it and thus the fans to kick in.

So my questions is if there’s anything else I could do to optimize it or the use of Windows apps through Wine Server is at fault?
In the second case, there’s anything I could do to make it work smother, like Windows?

Thanks and all the best!

Hi, what’s your cpu model?

CPU it’s Intel i7-7700HQ_CPU_@_2.80GHz


Just curios if you checked this and done accordingly

I use video-modesetting since I don’t need nvidia for my activities
apart from arch wiki page
I’ve also followed some fixing for heating problem, normal in this machine

Fixing heat


Have you tried undervolting a bit? i do it on my i7, helps a lot in the temps.
I use this app: GitHub - georgewhewell/undervolt: Undervolt Intel CPUs under Linux

Always start with small values as suggested.
I found my sweetspot at:

core: -130.86 mV
gpu: 0.0 mV
cache: -130.86 mV
uncore: 0.0 mV
analogio: 0.0 mV
powerlimit: 20.0W (short: 5.0s - enabled) / 15.0W (long: 8.0s - enabled)

You can also tweak TLP a bit. Try setting the min and max frequencies:

first execute in terminal: sudo tlp-stat -p

Note the min and max frequencies and adjust the config file.
My max frequency is 4.1gz. However that’s insane temps and most of the times i don’t need that, so i made the max at 3.2ghz. Your call, you can spend some time playing with the best values for you.
Also, tinker with the undervolt utility powerlimits, that also helps a lot

1 Like

you may also try auto-cpufreq from Manjaro repos

Hi Bogdan, thanks for the reply!

I knew about the arch link and from there I only set the thermal mode to balanced since in Windows I have a similar Dell app that was set to Optimized.

However, now it seems to be ok (similar to Windows).
In TLP-UI I set the CPU Energy to “balance_power” right before posting this and in the meantime the CPU usage dropped.

When I switched back to “balance_performance” (the default) it starts to heat and the fans RPMs are going up. So “balance power” seems to be ok for what I have to do.

PS: Salut, ma bucur sa vad un roman in Manjaro team :slight_smile:

1 Like

Thanks notageek, I didn’t know there are some physical optimizations… I have to check your article again.

Thanks Asylum… undervolting sounds interesting… I have to check it in depth!

1 Like

That is great, renders null the possibility of some hardware issue.

There is a mention about it in the wiki too, not sure tho the difference between the two packages mentioned there. From what i gathered it seems @Asylum has provided the most useful information.

tot mai multi romani utilizatori Manjaro :wink: