Dell XPS 15 9500 Killer Wi-Fi 6 AX500-DBS Driver

I got the new Dell XPS 15 9500 with the Killer Wi-Fi 6 AX500-DBS WIFI module.
Unfortunately, the Module is not recognized correctly and not usable.
In the device list, it looks like it is recognized as a Qualcomm Device 1101.

$ inxi -Fazy
  Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=04cfe330-0e09-4eff-bcf3-f50244307900 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: i3 4.18.2 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Dell product: XPS 15 9500 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0HH6JF v: A00 serial: <filter> UEFI: Dell v: 1.1.3 
  date: 05/08/2020 
  ID-1: BAT0 charge: 77.2 Wh condition: 77.2/84.3 Wh (92%) volts: 13.1/11.4 
  model: BYD DELL M59JH05 type: Li-poly serial: <filter> status: Full 
  Topology: 8-Core model: Intel Core i9-10885H bits: 64 type: MT MCP arch: N/A 
  family: 6 model-id: A5 (165) stepping: 2 microcode: C8 L2 cache: 16.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 76816 
  Speed: 800 MHz min/max: 800/5300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 801 11: 800 12: 800 13: 800 
  14: 800 15: 800 16: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9bc4 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1f95 
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-11:4 chip ID: 0c45:6d14 
  Display: x11 server: X.Org 1.20.8 driver: intel,modesetting,nouveau 
  alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2400 s-dpi: 96 s-size: 1016x635mm (40.0x25.0") 
  s-diag: 1198mm (47.2") 
  Monitor-1: eDP1 res: 3840x2400 hz: 60 dpi: 287 size: 340x210mm (13.4x8.3") 
  diag: 400mm (15.7") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.6 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:06c8 
  Sound Server: ALSA v: k5.8.3-2-MANJARO 
  Device-1: Qualcomm vendor: Bigfoot Networks driver: N/A port: 3000 
  bus ID: 6c:00.0 chip ID: 17cb:1101 
  Local Storage: total: 1.86 TiB used: 15.56 GiB (0.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM981a NVMe 2048GB size: 1.86 TiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 15301229 scheme: GPT 
  ID-1: / raw size: 1.08 TiB size: 1.06 TiB (98.34%) used: 15.49 GiB (1.4%) 
  fs: ext4 dev: /dev/nvme0n1p7 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 56.0 C mobo: N/A gpu: nouveau temp: 39 C 
  Fan Speeds (RPM): cpu: 2782 fan-2: 3101 
  Processes: 290 Uptime: 42m Memory: 62.56 GiB used: 2.58 GiB (4.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1039 lib: 269 
  Shell: Bash v: 5.0.18 running in: urxvtd inxi: 3.1.05 


$ lspci
00:00.0 Host bridge: Intel Corporation 10th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 02)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics (rev 05)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 02)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Comet Lake PCH Thermal Controller
00:13.0 Serial controller: Intel Corporation Device 06fc
00:14.0 USB controller: Intel Corporation Comet Lake USB 3.1 xHCI Host Controller
00:14.2 RAM memory: Intel Corporation Comet Lake PCH Shared SRAM
00:15.0 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #0
00:15.1 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #1
00:16.0 Communication controller: Intel Corporation Comet Lake HECI Controller
00:1c.0 PCI bridge: Intel Corporation Device 06b8 (rev f0)
00:1c.5 PCI bridge: Intel Corporation Device 06bd (rev f0)
00:1c.6 PCI bridge: Intel Corporation Device 06be (rev f0)
00:1d.0 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #9 (rev f0)
00:1e.0 Communication controller: Intel Corporation Comet Lake PCH Serial IO UART Host Controller #0
00:1f.0 ISA bridge: Intel Corporation Device 068e
00:1f.3 Audio device: Intel Corporation Comet Lake PCH cAVS
00:1f.4 SMBus: Intel Corporation Comet Lake PCH SMBus Controller
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller
01:00.0 3D controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] (rev a1)
02:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
03:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
03:01.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
03:02.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
03:04.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
04:00.0 System peripheral: Intel Corporation JHL7540 Thunderbolt 3 NHI [Titan Ridge 4C 2018] (rev 06)
38:00.0 USB controller: Intel Corporation JHL7540 Thunderbolt 3 USB Controller [Titan Ridge 4C 2018] (rev 06)
6c:00.0 Network controller: Qualcomm Device 1101 (rev 01)
6d:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5260 PCI Express Card Reader (rev 01)
6e:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983

I found other people having the same problems in other distros: mint ( ), Fedora ( ) and Ubuntu ( ).

Is there some way to get it to work in manjaro?

1 Like

As I see here:

The AX500 is not supported at this time, there is no upstream driver. This is why Dell is still using the AX1650 on the machines they are selling with Linux. This should by supported by the ath11k driver, which I think is targeted for linux 5.9 series kenels, and will likely be out in late fall. Closing as upstream, though I would expect if you want to run rawhide kernels, support should be there in 3-4 weeks.

It is just a matter of time. You could try to the newest kernel 5.9 and see if it works there. The firmware should be there at least in /usr/lib/firmware/ath11k (which is not yet there), only ath10k and below. I think when 5.9 become stable the Linux firmware is published also.

Here you can search what has been committed:

5.9 did not work for me for the ax500 on xps 15 9500 i9.

Kernel 5.9.0-1-MANJARO makes no difference to me, too.

Is there any way to have a driver for the module right now?

1 Like

No, it just don’t exist at the moment. Here are the supported chipsets:

FYI: Still no Wifi/Bluetooth support for the XPS 9500 i9 with kernel linux59 5.9-rc6 (from latest stable release).

Just updated to 5.9.1-1-MANJARO (on stable). As it seems, there is still no support for the ABS-Killer Wifi AX500…

According to thread on LKML everything should work fine on 5.10.0-1-MANJARO. However, I tried that and still not working - I cannot event load athk11_pci kernel module which should handle it.

I’ll try to build custom kernel and apply additional firmware suggested in ath11k-firmware - stay tuned :wink:

1 Like

Yes, I can confirm that rebuilding a 5.10.0-1-MANJARO kernel with the following additional config set and applying firmware solves the issue:

1 Like

Have you a snippet to include the Firmware into the kernal?

# clone firmware
git clone

# Install firmware
cd ../ath11k-firmware
sudo mkdir -p /lib/firmware/ath11k/QCA6390/hw2.0/
sudo cp QCA6390/hw2.0/1.0.1/WLAN.HST.1.0.1-01740-QCAHSTSWPLZ_V2_TO_X86-1/*.bin 

sudo cp QCA6390/hw2.0/board-2.bin /lib/firmware/ath11k/QCA6390/hw2.0/

Or you can simply install linux-firmware released after 30.10.2020, which should include needed files.

Update: One issue I see so far is that when you go to the suspend mode and go back the WIFI stops working and after a restart, it works sooo slow :cry: I hope that it will be fixed soon…

Update 2: If you restart WIFI device everything is going back to normal - so some good workaround until driver will be improved :wink:

1 Like

Big thx,
Thononly issue in this kernal is ist Worms not with the Nvidia Driver :sob:

@Beardcoder I can’t paste any links (don’t know why) but have you tried going to packages/extra/linux510-extramodules/nvidia on the Manjaro Gitlab page that hosts their kernel? It looks like there is some patch for Nvidia Driver :slight_smile:

1 Like

@mzabielski Sorry for my question. Iam new in Linux :sweat_smile:
How can i include that? I found nothing :see_no_evil:

After updating to 5.10.7-3-MANJARO it worked for me, without any problems!

I incorporated some patches that fix the suspend issue with AX500-DBS and it seems to work as expected after suspend and wakeup: GitHub - trustin/linux510-qca6390: Arch/Manjaro Linux Kernel PKGBUILD with QCA6390 (AX500-DBS) support. Enables WiFi on Dell XPS 13" 9310.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.