Dell XPS 15 7590 laptop crashing, dual GPU issue

This laptop comes with intel integrated graphics and geforce 1650. I think issue happens because OS tries to use both GPU at the same time or is not properly switching from one to another.

Normally I’m using vscode, chrome and firefox.

When it crash it happens:

  1. Screen goes to full yellow color and freezes. Hold power off button and power on again. Now screen starts to flickering. After 2 reboots it solves the flickering.
  2. App that I’m using freezes, after a moment it will prompt if I want to force quit. Click on quit. I can’t power off/reboot the machine, bash doesn’t work and a few more thing. Had to hold power off button.

I tried to disabled Intel GPU on bios but I didn’t see the option nor dedicated gpu. I think I have a MUXLESS laptop.

So, I need a way to disable Intel GPU and use Nvidia only.

Branch: Stable
Desktop Environment: GNOME Lysia 20.0.3
CPU: i7 7590
GPU: Intel UHD graphics and Geforce 1650 laptop
GPU Driver: None
Kernel: 5.6.15-1-MANJARO

Kernel 5.6 is no longer supported by Manjaro. Before update you should always read forum announcements. If a kernel is deprecated you need to install another kernel, boot into that, remove the deprecated kernel and THEN you can update.

Is the Kernel that comes from GNOME dist (Manjaro - Gnome), I didn’t update since installation.

Did you install any program? Without updating you might break the system if you install programs. Manjaro is a rolling release distro, it’s expecting you to update whenever an update is available.

Yes, I have few programes installed. I will try to update and see if that solves the problem. Thanks.

First, install another kernel, boot into it and remove 5.6!!! :wink:

you can do

sudo mhwd-kernel -i linux57
sudo mhwd-kernel -i linux58

reboot and after

sudo mhwd-kernel -r linux56

I have an ASUS laptop with a GeForce 1650 and the intel UHD graphics 630. Take a look on Optimus Manager. That’s what I use on my laptop and it works. I use XFCE though not GNOME. I also use optimus-manager-qt. With Optimus Manager you can use NVIDIA only.

I have linux57 and linux58 installed. Now it doesn’t pass from Dell’s logo (after boot menu). tty2 works and I can login into my user. Is using 5.8.3-2-MANJARO

see in log

sudo journalctl -b0 -p4

Don’t know why but booting manjaro from a usb and then rebooting the computer solved the problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.