Dell optiplex 7050 micro, it wont shut down "completely"

Iv just brought a used Dell Optiplex 7050 after doing a lot of checking for a nice stable linux based “thin” client.

Problem is it will not shutdown. Even from a live stick. Windows works just fine.

It will just hang forever at the point where it is supposed to switch the system off. Can not access any terminals with Ctrl+Alt+F keys , F1 does nothing either.

I have tried :-
tried many BIOS setting, turned off all wake on lan and/or USB etc
also turned off virtulization.

tried apm=power_off acpi=force intel_iommu=off, there was also sugettion to remove “quite” and “wake” so i tried that too.

GRUB_CMDLINE_LINUX_DEFAULT=“udev.log_priority=3 apm=power_off acpi=force intel_iommu=off”

The BIOS is fully up to date ver 1.26.0

Just looking at the last few lines of the journalctl, it looks to be ending linux as far as linux can see.

journalctl -b -1

Oct 20 22:08:11 greg-optiplex7050 systemd[1]: Shutting down.
Oct 20 22:08:11 greg-optiplex7050 systemd-shutdown[1]: Syncing filesystems and block devices.
Oct 20 22:08:11 greg-optiplex7050 systemd-shutdown[1]: Sending SIGTERM to remaining processes…
Oct 20 22:08:11 greg-optiplex7050 systemd-journald[224]: Received SIGTERM from PID 1 (systemd-shutdow).
Oct 20 22:08:11 greg-optiplex7050 systemd-journald[224]: Journal stopped

Im at a loss :frowning:

❱inxi --admin --verbosity=7 --filter --no-host
  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=885a2b3e-3404-4ba8-b0ab-9dcfcff35d84 rw udev.log_priority=3
    apm=power_off acpi=force intel_iommu=off
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 7050 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 055H3G v: A01 serial: <superuser required> UEFI: Dell
    v: 1.26.0 date: 08/20/2023
  Message: No system battery data found. Is one present?
  System RAM: total: 16 GiB available: 15.49 GiB used: 3.28 GiB (21.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF4
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 875 high: 900 min/max: 800/3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 900 3: 900 4: 900
    bogomips: 27208
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: DP-1
    empty: DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:5912 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
    s-diag: 582mm (22.9")
  Monitor-1: DP-1 model-id: RTK 0x1d1a serial: <filter> built: 2015
    res: 1920x1080 hz: 60 dpi: 305 gamma: 1.2 size: 160x90mm (6.3x3.54")
    diag: 1168mm (46") ratio: 16:9 modes: max: 1024x768 min: 720x400
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 630 (KBL GT2)
    device-ID: 8086:5912 memory: 15.13 GiB unified: yes
  API: Vulkan v: 1.3.264 layers: 1 device: 0 type: integrated-gpu name: Intel
    HD Graphics 630 (KBL GT2) driver: mesa intel v: 23.1.9-manjaro1.1
    device-ID: 8086:5912 surfaces: xcb,xlib
  Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15e3 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24fd
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:4 chip-ID: 8087:0a2b
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0104
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 968.58 GiB used: 32.35 GiB (3.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KXG50ZNV1T02
    NVMe 1024GB size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: AADA4101
    temp: 42.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Transcend model: JetFlash 16GB
    size: 14.71 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
    fw-rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 852.87 GiB size: 838.41 GiB (98.30%)
    used: 32.31 GiB (3.9%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
    label: N/A uuid: 885a2b3e-3404-4ba8-b0ab-9dcfcff35d84
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 34.2 MiB (35.6%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 9C53-43DC
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs label: Recovery
    uuid: 02B25309B2530119
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 100.37 GiB fs: ntfs label: N/A
    uuid: FAC45710C456CF0F
  ID-4: /dev/sda1 maj-min: 8:1 size: 3.63 GiB fs: iso9660
  ID-5: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: A19E-3AF4
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-3:2 info: Microsoft Wired Keyboard 600 (model 1576)
    type: keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 1.5 Mb/s (183 KiB/s) lanes: 1 mode: 1.0 power: 100mA
    chip-ID: 045e:07f8 class-ID: 0300
  Device-2: 1-7:3 info: Maxxter Wireless Receiver type: mouse,keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 50mA chip-ID: 248a:8514 class-ID: 0301
  Device-3: 1-9:4 info: Intel Bluetooth wireless interface type: bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 power: 100mA chip-ID: 8087:0a2b class-ID: e001
  Hub-2: 2-0:1 info: super-speed hub ports: 10 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Device-1: 2-1:2 info: Transcend Information JetFlash type: mass storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s (596.0 MiB/s)
    lanes: 1 mode: 3.2 gen-1x1 power: 304mA chip-ID: 8564:1000 class-ID: 0806
    serial: <filter>
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 217 Uptime: 4m wakeups: 0 Init: systemd v: 254 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: pm: pacman
  pkgs: 1369 libs: 399 tools: pamac,yay pm: flatpak pkgs: 0 Shell: fish
  v: 3.6.1 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.30

What are you using for shutdown?
What happens if, for example, you do any of the following:
systemctl poweroff
systemctl poweroff --force
systemctl halt
systemctl halt --force

(theres also --force --force but thats a bit more wild and doesnt wait for anything to close)

They all do the same,

Visible and audible symptoms:-
linux seems to end, but the processor fan is still going, the power light is still on and the screen is just black.
System has to be forced to shutdown by holding the power button.

Since Windows works - expected - you may need to instruct your system to report a windows version.

O my blood pressure :frowning:

I think i have tried all of them, but im not sure if editing stuff in the grub boot menu (Edit mode) then hitting F10, wait for it to boot, then try a shutdown? but i have tried all of them that way.

acpi_os_name=“Microsoft Windows NT”



other strings to test:

"Microsoft Windows XP"
"Microsoft Windows 2000"
"Microsoft Windows 2000.1"
"Microsoft Windows ME: Millennium Edition"
"Windows 2001"
"Windows 2006"
"Windows 2009"
"Windows 2012"
when all that fails, you can even try "Linux"

Does this mean to try all of these with both acpi_os_name and then again with acpi_osi? if so, when i do all the acpi_osi do i add the ! to the start of all of them?

I have found that if i hit “UEFI firmware settings” in the grub menu that it will reboot (including a full shutdown) so why can it do it after loading Manjaro?

I thought i had a chance as i just figure how to get to the MEBx control, a lot of posts on the net talk about tinkering in here, but mine does not have a

“state control” option.

should i try any of these?

The link provided above says

" Out of curiousity, you can follow the steps below to extract your DSDT and search the .dsl file. Just grep for “Windows” and see what pops up.

So if it means anything to anyone?

❱cat dsdt.dsl | grep -i windows
                If (_OSI ("Windows 2001"))
                If (_OSI ("Windows 2001 SP1"))
                If (_OSI ("Windows 2001 SP2"))
                If (_OSI ("Windows 2001.1"))
                If (_OSI ("Windows 2006"))
                If (_OSI ("Windows 2009"))
                If (_OSI ("Windows 2012"))
                If (_OSI ("Windows 2013"))
                If (_OSI ("Windows 2015"))
            Name (_HID, "PNP0C14" /* Windows Management Instrumentation Device */)  // _HID: Hardware ID
            Name (_CID, EisaId ("PNP0D80") /* Windows-compatible System Power Management Controller */)  // _CID: Compatible ID
            Name (_HID, "PNP0C14" /* Windows Management Instrumentation Device */)  // _HID: Hardware ID
    Name (W98S, "Microsoft Windows")
    Name (NT5S, "Microsoft Windows NT")
    Name (WINM, "Microsoft WindowsME: Millennium Edition")
    Name (WXP, "Windows 2001")
    Name (WLG, "Windows 2006")
    Name (WIN7, "Windows 2009")
    Name (WIN8, "Windows 2012")
    Name (WN81, "Windows 2013")
            Name (_HID, "PNP0C14" /* Windows Management Instrumentation Device */)  // _HID: Hardware ID

Try kernel 6.4. For me this one works.
Havent really found a solution but to go to older kernel untill prob is solved in kernel.

1 Like

Hi @superthug , I shall try that in just a sec

I just wanted to add to the thread that iv spent the morning trying different distros and it looks like it just Manjaro ! , I have tested Mint, Ubuntu and MX these all work just fine.

I have spent years on Manjaro and really really dont want to have to change :frowning:

Lets keep finger crossed for downgrade of kernel.

I understand the frustration hehe
I have 2 of those Dell micros and 2 HP micro G4.
The HP ones work fine so it’s def something with 6.5 kernel and the Dell ones.
Going back in kernels i never like as a final solution but temporary.
Good luck!

1 Like

Yep !! , that did it :smiley:

I cant thank you enough @superthug

So you went back to 6.4 but would a LTS not be better?

Has this bug been reported to the kernel devs, is it likely to get fixed?

lol, yea, i brought this because my laptop that i had been using will not go to sleep when you close the lid (just sometimes though) so you came back in the morning to find its been on all darn night. So i got this system to try and alleviate my headache. There is a thread on here somewhere, never got fixed though, still does it.

I guess if you have no problem using 6.4 then just keep it.
Not sure if this was solved. I havent digged into this further

Kernel 6.4 is End Of Life and won’t be updated anymore. Install another kernel in addition to be prepared when the kernel got removed from repos. Read Announcements before updating your system.

Which other kernel, any? how does that prepare ? cant we just not update the kernel any more until we are sure its been fixed.

Partial upgrades are not supported.
It makes sense for you to keep the latest LTS moving forward (thats 6.1).
Check newer kernels as they become available.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.