Dell latitude 5400 boots to a black screen without cursor

I have installed manjaro 20.0 Lycia on my new Dell latitude 5400 laptop. Manjaro is working fine. But suddenly yesterday when I restarted, it shows Dell logo and then just a black screen appears. It remains until the battery becomes empty. It doesn’t even show a cursor or error message!! I can sometime access the system using a bootable usb drive. When it shows welcome screen then I select “detect bootloader” option and it shows (hd1, gpt1). I press enter and if my luck is good enough it normally shows manjaro login screen and I can use without any issues. Otherwise black screen. I tried many solutions including kernel downgrading, re-installing grub etc. Now I am tired and frustrated. I wish if anybody can understand and help me… In my 7 years old laptop I also use manjaro but not a single problem! So why new machine is creating problem!! Please help!! Thanks in advance.

Hello, does your machine boots on a recent Manjaro iso on USB key ?

Hello, are you able to boot the recent Manjaro Desktop ISO? If so then it would be nice to get a log what happend there.

  1. Boot the iso.
  2. open a terminal
  3. open browser and go to
  4. type manjaro-chroot -a into the terminal and type 1
  5. then run
journalctl -b -0 --no-pager | curl --upload -
  1. Paste the link here.

Also useful:

inxi -Fazy
sudo parted -l


1 Like

No! Its black when I press boot option during installation but previous version installs without any problem. But creates the problem I mentioned.

The recent 20.1 iso shows black screen from the beginning when I press boot option in the welcome screen. :disappointed_relieved: Thats why I chose the old version that’s already running in my old laptop without any issues.

I was able to login don’t know how. I have tried the commands you provide and the following is the output:

  1. manjaro-chroot -a
==> ERROR: You can't mount 0!
  1. journalctl link:
  2. inxi -Fazy
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=0d7e81ae-e848-48f0-86de-53f0fdbae1a9 rw quiet apparmor=1 
  security=apparmor resume=UUID=9bef5d86-da38-47ea-91c2-b4e4c5ece51f 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Latitude 5400 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0PD9KD v: A00 serial: <filter> UEFI: Dell v: 1.7.4 
  date: 05/12/2020 
  ID-1: BAT0 charge: 7.2 Wh condition: 65.3/68.0 Wh (96%) volts: 7.8/7.6 
  model: BYD DELL 9JRYT03 type: Li-poly serial: <filter> status: Charging 
  Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) microcode: D6 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 900 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 901 5: 900 6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3ea0 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-6:2 chip ID: 0bda:5539 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1368x768 s-dpi: 97 s-size: 360x202mm (14.2x8.0") 
  s-diag: 413mm (16.3") 
  Monitor-1: eDP1 res: 1368x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:9dc8 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel 
  port: 3000 bus ID: 00:14.3 chip ID: 8086:9df0 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Dell driver: e1000e v: 3.2.6-k 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15be 
  IF: eno2 state: down mac: <filter> 
  Local Storage: total: 506.36 GiB used: 11.59 GiB (2.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS512G NVMe KIOXIA 512GB
  1. sudo parted -l
Model: KBG40ZNS512G NVMe KIOXIA 512GB (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name  Flags
 1      2097kB  317MB  315MB   fat32                 boot, esp
 2      317MB   494GB  494GB   ext4
 3      494GB   512GB  18.3GB  linux-swap(v1)        swap

Maybe try with a different USB stick. But please keep the latest iso, not an old one.

I think you didn’t understand what I said about the new one.

While reading the boot.0.log i saw this:

ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored

The linux ACPI always tells the firmware that it is windows, but there is code on the firmware that supports linux. Here it becomes ignored, but to work well, some systems need this. To enable this you could add:


to the kernel parameters in grub:

Have look here at the acpi section: [HowTo] Power savings setup| 2021-01-25

That’s the reason why i said:

and not 0 :wink:


I have had this with my Latitude 7440, too. But only when it is attached to the Docking Station and has a secondary/external Monitor active and connected.

Temporary fix / Try this out:
In GRUB, edit boot menu parameters, delete “quiet” from boot string. There is a key you can press when the menu shows that will allow for a one time change of the boot parameters.

If systems boots (now showing boot text in text console, that’s what “quiet” suppresses), that is your solution. Make it permanent by editing GRUB menu to exclude “quiet” option. (easiest by installing a GRUB editor or do a web search on the commands you need to edit and rebuild the GRUB menu by hand).

Fingers crossed, hope it helps!