Dell laptop will not ramp up fans

Hello there!

I have a Dell Vostro 5510, running Gnome manjaro, kernel 5.15.102-1-MANJARO.

I’am having a constant problem with the fans, that they don’t ramp up to keep the CPU cool.
When i hit 100% usage, the frequenct drops to 800MHz to 1.2GHz, the fan is bearly audible.
The same model laptop running ubuntu ramp the fans to max to keep it cool.

I tried installing fan controls, but lm-sensors does not find a pwm fan. inxi -Fazy show Fan Speeds (RPM): N/A.

Is there any way to ramp then up manualy? Or i’m stuck with a laptop that cannot cool itself?

EDIT: I have the cpu_governor set to performance, but this happens with powersabe as well

Isn’t this the expected behavior? A quiet system? Fans are controlled by the BIOS on most laptops, therefore no fan speed is reported.

Why does ubuntu ramp up the fan? Maybe because the cpu driver is different? Nowdays it is intel_pstate on intel cpu, before it was acpi_cpufreq.

 LANG=C cpupower frequency-info

I remember I had to install i7z and enable it’s accompanying service for automatic fan control.

Since you didn’t give system information other that a brand name, there’s not much to go on.

I normally would agree with it, but the same model of laptop (even the same machine) running other OS ramps up the fan to an audible speed istead of pulling clock. BIOS is set to max cpu fan and speed.

I checked on other identical machine runnig ubuntu, they use the same driver.

I installed it, but didn’t find the fan control :confused:

Sorry about that, how can i get it? :slight_smile:

Is there any noticeable heat up of the cpu?

Maybe the difference is that Manjaro uses tlp, while Ubuntu does not? Tlp set the the cpu my default to powersave.

Maybe check this file: /etc/tlp.conf and also provide:

sudo tlp-stat --verbose

Btw… How did you ensure that you really burn the cpu? I mean, normally it clocks up as needed. If it stays at 100% with 1200Mhz then it uses 1200Mhz at 100%. I would say it, it doesn’t need more power, therefore it doesn’t clock up. :man_shrugging:

does this happen intermittently?

do you get results for;

$ cat /proc/i8k

should get something like;
1.0 A14 -1 51 -22 3 -22 0 -1 -22

by default on most dell laptops fan speed control is handled by BIOS and from personal experience, it remains the best at it. you should do least to interfere if you can afford to. having said that there are ways you can override, though YMMV.