Deleting a orphaned program link from the right-click app list on desktop

Greetings, total newbie here, but truly enjoying the speed of Manjaro on a 2011 Mac. As you are aware sometimes the little challenges can be a hurdle. Tried to install Darktable, found later processor to weak on this Mac. Removed app, but the app name is not removed from the desktop/right-click app list (under Run Program). How do I get rid of this program entry that points to a removed program please?

Hi @Lucas0511, and welcome!

Please provide the output for:

ls -l ~/.local/share/applications


When providing terminal output, copy the text and paste it here, wrapped in three (3) backticks. Like this:

pasted text

This will just cause it to b e rendered like this:

Lorem nisi
morbi tristique
ac a
sem molestie hendrerit
quam a amet
massa nulla magna.

Instead of like this:

Lorem nisi morbi tristique ac a sem molestie hendrerit quam a amet massa nulla magna.

Thereby improving legibility and making it easier for those trying to be of assistance.

Thanks, here the requested:

total 92
-rwxr-xr-x 1 user user 282 Nov 16 20:15 Launchpad.desktop
-rw-r–r-- 1 user user 23752 May 25 2021 pamac.manager.desktop
-rw-r–r-- 1 user user 3140 Nov 11 13:59 shotcut_shotcut.desktop
-rw-r–r-- 1 user user 5244 May 25 2021 xfce4-about.desktop
-rw-r–r-- 1 user user 4505 May 25 2021 xfce4-session-forcequit.desktop
-rw-r–r-- 1 user user 4456 May 25 2021 xfce4-session-lockscreen.desktop
-rw-r–r-- 1 user user 4439 May 25 2021 xfce4-session-logout.desktop
-rw-r–r-- 1 user user 4480 May 25 2021 xfce4-session-restart.desktop
-rw-r–r-- 1 user user 4448 May 25 2021 xfce4-session-sleep.desktop
-rw-r–r-- 1 user user 8403 May 25 2021 xfce-settings-manager.desktop

How did you uninstall darktable? The .desktop file is /usr/share/application/darktable.desktop. It should have been removed automatically. If not remove it.

Thank you. I don’t see it there, so the next place to check for it is in /usr. Please post the output of:

sudo find /usr -iname '*.desktop`

And thank you for wrapping the terminal output. However, I meant three backticks, a.k.a. accent, a.k.a grave accent symbols, and not single quotes that you appear to bee using. (` not '). The key’s location depends on your keyboard layout. If, however, you use en_US, like me, it is the key just left of the 1:

Thank you, that request just results in a rather empty


I tried to install darktable with Pacman, which seemed fine. But could never get darktable to start, yet it was showing installed. With Pacman I could not remove it, so I installed Octopi where it was not showing either. So reinstalled in Octopi, hoping removing darktable there would also get rid of the orphaned menu item for it.

In local/usr/share/applications there is no entry for darktable

You see how challenges like this can quickly discourage an optimistic user.

darktable.desktop is not there, thanks for stepping in.

Then let’s look for it wherever it is. Please provide the output of:

sudo find / -iname '*table*.desktop'


find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied

Snap? Well, that would explain it then, I guess. You need to uninstall the snap:

sudo snap remove darktable

Guess that was the attempt in the very beginning. Thank you for bearing with me. User always the weakest link. Thank you for your guidance, plus learned something today. Appreciated, blessings. Lucas

1 Like

That is the most important thing.

You are very welcome!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.