Delete key not working if I disable the delete file shortcut

I don’t like my kde have a trashbin since I knows what I am deleting.
thus I disable the delete key shortcut to prevent accident press of a delete key.

Then an unexpected thing happened, I cannot use delete key to delete anything. I cannot delete a char I am typing in kde(but, in my browser, I could use the delete key.)

I tried several weeks and finally found that, active the delete shortcut is the only way to make delete key function in KDE.

I thought it might be a bug.
Is there any idea about the unexpected thing?

Famous Last Words… :roll_eyes:

It’s not. It was designed that way.

If you want to delete something without sending it to the trash can, use Shift+Del.

1 Like

sorry for not reply for a long time.

The reason I disable the delete hotkey is that, I don’t want to move anything into trashbin.
And I once move some of them by press delete without press shift accidently.

The question is, once I disable the delete hotkey, I cannot even delete a char in KDE

Is it normal? Where could I both keep the delete key funcion in text editor, while disable its hotkey which binding to delete a file?

Then you must make it a habit of pressing Shift+Del instead of just Del. :man_shrugging:

Yes, it is.

1 Like

Because disabling the “hotkey”, as you call it, is just disabling the Delete key, thus functionality of the key in total, on the keyboard. It’s not more granular than that. To press Delete means you’re doing just that.

Of course there are other modifiers, but they add to the default, commonly accepted functionality.


Maybe my English is not good enough, what I met is that, when I delete the shortcut/hotkey from this entry, delete key does not work.

(Link to screenshot, deleted since it is indeed a bug which is recorded in KDE’s bugtracker)

As you can see, the only word of this shortcut is “Move to Trash”.
It does not and should not implies to “disable delete key”.

This is why I asked “is it normal”.

BTW, I tried assign a custom key, “Ctrl+Shift+Alt+Z”, to this shortcut, and then Ctrl+Shift+Alt+Z could be used to delete a char in KDE based text editors.

If you assist that “delete means move to trash”, then it should be a bug, since the char is not moved to trash.

Bwahahaha, way to go, KDE! :ok_hand: Just confirmed it myself. It is indeed a bug. Disabling the “Shortcut” for Delete to send a file to the Trash also has the side-effect where you can no longer use the delete command to rename a file.


I don’t even feel like filing a bug report. I’ve had more than my fill of the developers’ procrastination and back-and-forth fart sniffing recently.


when I tried to file a bug… I found:

This is an old problem.

See what I mean? This has been a familiar pattern on their bug reports.

They try to fix things…

They end up breaking other things…

They’re not sure how they messed up…

They try to justify their decision…

They stall, stall, stall, procrastinate, etc, etc, etc, and the bugs just remain for years.

They’ll tell you it’s not a bug. Then it is a bug. Then they give you some esoteric reason why it cannot be fixed without redoing KDE from scratch by finding a cure for cancer with a rare floral ingredient found only in the deepest tropical jungles that blooms one day each year just before the sun sets, and blah, blah, blah.

I’ve had conversations with a few other KDE users over email (bumping into each other through bug report comments), and they share the same sentiment: there’s no point in filing bug reports against KDE because of the constant foot-dragging and developers’ not being forthcoming about real issues.

It’s like a running joke at this point.

I’m sure others have better luck and experience, but it’s been a frustrating experience for me.

Derrick: Here’s a bug. Here’s my system info. Here’s a video of it. Here’s how to reproduce it. Here’s some additional info.

Nate (KDE): This is by design. Our users love it! :smiling_face_with_three_hearts: I’m sure you’ll end up loving it too.

Derrick: It’s a bug. It makes no sense. It shouldn’t be doing this, this, and this.

(months later) :spiral_calendar:

Sarah: Wow! I got the same issue! Here’s my info.

Nate (KDE): I must consult with my other developers to figure out if this really is a bug.

Nate (KDE): Okay, it’s a bug. But it’s really confusing. Looks like something broke when we tried to create a fancy new feature that our “users” supposedly requested some time ago. (Trust me, bro.) We’ll have to figure out a way to fix it, I guess. :man_shrugging:

(three years later) :spiral_calendar:

Derrick: Is anyone even trying to address this bug?

(crickets) :cricket: :cricket: :cricket:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.