Default boot to external montor

Hello, this is my first post so apologies in advance for any mistakes :grimacing:

I have an MSI laptop(1) and an HP external monitor(2) connected via HDMI, and set my external monitor(2) as primary display.
Now all works butter-smooth except a minor inconvenience: every time I boot my laptop, the login screen appears in my laptop display(1) instead of my external monitor(2) (hp monitor appears as if it’s not connected). After I log in, my external monitor(2) becomes active & primary. After logging out, the login screen appears on external(2) as it should, just not on the first boot. What settings do I need to tweak for the login screen to appear on my external monitor(2) on first boot?

TLDR: How can I activate my external monitor as primary on first boot (show login screen there)?

  Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5 
  tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
  Type: Laptop System: Micro-Star product: GE62VR 7RF v: REV:1.0 serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Micro-Star model: MS-16JB v: REV:1.0 serial: <filter> UEFI: American Megatrends 
  v: E16JBIMS.31A date: 09/05/2018 
  ID-1: BAT1 charge: 37.9 Wh condition: 38.6/53.4 Wh (72%) volts: 12.2/10.9 
  model: MSI Corp. MS-16JB type: Li-ion serial: N/A status: Unknown 
  RAM: total: 15.52 GiB used: 2.09 GiB (13.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake 
  rev: 9 L2 cache: 6144 KiB bogomips: 44817 
  Speed: 900 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 
  5: 900 6: 900 7: 900 8: 900 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 
  bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de 
  ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu 
  fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc 
  nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi 
  vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Micro-Star MSI 
  driver: nvidia v: 455.28 bus ID: 01:00.0 chip ID: 10de:1c20 
  Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus ID: 1-11:6 
  chip ID: 5986:0683 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting,nvidia 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa resolution: 1: 1920x1080~60Hz 
  2: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:a171 
  Sound Server: ALSA v: k5.8.16-2-MANJARO 
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel 
  port: e000 bus ID: 02:00.0 chip ID: 8086:24fb 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Micro-Star MSI 
  driver: alx v: kernel port: d000 bus ID: 03:00.0 chip ID: 1969:e0b1 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 1.14 TiB used: 196.04 GiB (16.8%) 
  ID-1: /dev/sda vendor: SanDisk model: SD9SN8W256G size: 238.47 GiB speed: 6.0 Gb/s 
  serial: <filter> rev: 7000 scheme: GPT 
  ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A3U0 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUD0N rev: 1.00 dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  Message: No RAID data was found. 
  ID-1: / size: 68.22 GiB used: 30.52 GiB (44.7%) fs: ext4 dev: /dev/sda6 label: N/A 
  uuid: 1bfb7bb9-b827-4db9-bd61-3e4117bb5041 
  ID-2: /boot/efi size: 296.0 MiB used: 44.5 MiB (15.0%) fs: vfat dev: /dev/sda1 
  label: SYSTEM uuid: 7427-F937 
  ID-3: /run/media/florian/Secondary size: 200.00 GiB used: 165.48 GiB (82.7%) fs: ntfs 
  dev: /dev/sdb2 label: Secondary uuid: 5CCE05FBCE05CDE8 
  Alert: No Swap data was found. 
  ID-1: /dev/sda2 size: 128.0 MiB fs: <superuser/root required> label: N/A uuid: N/A 
  ID-2: /dev/sda3 size: 166.80 GiB fs: ntfs label: N/A uuid: 449EAA589EAA41F2 
  ID-3: /dev/sda4 size: 570.0 MiB fs: ntfs label: N/A uuid: 78EC7F11EC7EC940 
  ID-4: /dev/sda5 size: 900.0 MiB fs: ntfs label: WinRE tools uuid: 5C3C30503C302802 
  ID-5: /dev/sdb1 size: 713.97 GiB fs: ntfs label: Data uuid: 225835A25835761F 
  ID-6: /dev/sdb3 size: 17.54 GiB fs: ntfs label: BIOS_RVY uuid: 5CB63721B636FB5A 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 1-3:2 info: Holtek USB Laser Game Mouse type: Mouse,Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 04d9:fc12 
  Device-2: 1-4:3 
  info: MosArt 2 4Ghz Wireless Transceiver [for Delux M618 Plus Wireless Vertical Mouse] 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 062a:4c01 
  Device-3: 1-7:4 info: MSI steel series rgb keyboard type: HID driver: usbhid 
  interfaces: 1 rev: 1.1 speed: 12 Mb/s chip ID: 1770:ff00 serial: <filter> 
  Device-4: 1-10:5 info: Intel Wireless-AC 3168 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aa7 
  Device-5: 1-11:6 info: Acer BisonCam NB Pro type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 5986:0683 serial: <filter> 
  Device-6: 1-12:7 info: Realtek RTS5129 Card Reader Controller type: <vendor specific> 
  driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  chip ID: 0bda:0129 serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 58.5 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 245 Uptime: 30m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1212 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

The video output at boot time is determined by the BIOS, not the operating system.
If at all you will find an option in your laptops BIOS, which i doubt.

Sorry for not being more specific - I am not trying to start the grub boot on my external, just the login screen once Manjaro is loaded. I have this setting on my Windows 10 which projects the first login screen on my external(2), and was wondering if Manjaro offered the same option?

System Settings -> Display and Monitor -> Display Configuration
You can define the primary monitor there.

Maybe this is what you are looking for.

I think he says he already did that. And that probably won’t work for login screen. At least on xfce with lightdm (what i tried it on) it doesn’t.

@flori here is what i found, maybe you can use this to disable the laptop screen so the login screen defaults to external monitor?

1 Like

If you think he already did that you might quote where he did that, maybe i am in reading troubles without noticing.
However, he’s not on xfce with lightdm, he’s on KDE Plasma 5.19.5 according to his inxi output. The laptop seems to run on nvidia gpu which would make it easy to edit the nvidia.conf according to the desired screen setup though, if this is the cause.

Thanks that’s exactly what I needed! Now my login screen appears on my external display. In case someone is looking for the same solution, use sudo nano instead of sudo vim if vim does not work.

I just got one more question - disabling my laptop screen has made Manjaro really laggy (5-6 seconds delay until a single keyboard key is pressed), any idea why that happened?

P.S. @440Hz I mentioned having set the primary display in the beggining :stuck_out_tongue: I have an MSI laptop(1) and an HP external monitor(2) connected via HDMI, and set my external monitor(2) as primary display.

1 Like

Sorry @flori don’t know why it makes it laggy for you. I knew the answer to this because I needed to do something similar with my desktop monitor and TV and I didn’t face the laggy delay problem.

But my system is different from yours given that I use an xfce desktop with lightdm. Maybe someone with more specific knowledge might be able to help further.

@440Hz He mentioned setting the external as primary but the login screen didn’t show up on only the external screen. From my experience, this can be solved by setting an xrandr script which runs before any of the display managers run. So it should be agnostic to the DE and the DM. However, calling this xrandr script is done differently for the DMs, which is why I linked the sddm one.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.